Mautic Community Forums

Not able to delete events from builder

After upgrading to 1.2.2, when I insert a new object in the campaign builder (ex. “open email”) I’m not able to delete it anymore (I click the cross but nothing happens).

Thank you for any suggestion

After upgrading to 1.2.2, when I insert a new object in the campaign builder (ex. “open email”) I’m not able to delete it anymore (I click the cross but nothing happens).
Thank you for any suggestion

It works for me. Could you press F12 to open the dev tools, navigate to the Console tab and then try to delete the node in the Campaign Builder. Do you see some javascript error message?

The only error I see is in the log (From Mautic System Info):

[2015-11-04 11:43:19] mautic.ERROR: Fatal: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set ‘always_populate_raw_post_data’ to ‘-1’ in php.ini and use the php://input stream instead. - in file Unknown - at line 0 [] []

in firebug, under console I see no errors. I get this response:

{“mauticContent”:“campaignEvent”,“success”:1,“route”:false,“eventId”:“new343ef84cba7764343e26b3ef369c1464a59f27a2”
,“deleted”:1,“event”:{“canvasSettings”:{“droppedX”:“1339”,“droppedY”:“520”},“name”:“kuyui”,“triggerMode”
:“immediate”,“triggerDate”:null,“triggerInterval”:1,“triggerIntervalUnit”:“d”,“properties”:{“points”
:9},“type”:“lead.changepoints”,“eventType”:“action”,“campaignId”:“2”,“buttons”:{“save”:""},“settings”
:{“label”:“Adjust lead points”,“description”:“Increase or decrease points”,“formType”:“leadpoints_action”
,“callback”:"\Mautic\LeadBundle\Helper\CampaignEventHelper::changePoints"},“tempId”:“new343ef84cba7764343e26b3ef369c1464a59f27a2”
,“id”:“new343ef84cba7764343e26b3ef369c1464a59f27a2”}}

<title>Site is offline</title>

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<link rel="icon" type="image/x-icon" href="/media/images/favicon.ico" />
<link rel="stylesheet" href="/media/css/libraries.css" />
<link rel="stylesheet" href="/media/css/app.css" />

The site is currently offline due to encountering an error. If the problem persists , please contact the system administrator.

System administrators, check server logs for errors.

Ok. So the error message is also telling you how to fix it:

Could you give it a try?

And of course it works… Thank you very much.

Having the same problem. But I am on a shared host environment and I don’t believe I have access to php.ini. Is there another solutions?

Thanks
Chris

Have you tried to contact your hosting provider and ask them to configure it for you?

Appreciate this is a year old now, but I thought I’d add something to this. In cPanel, the recommended way you edit the php.ini via the “PHP Configuration Editor” in the WHM interface.

If you go to this tool, then “Advanced Mode”, you have a radio button where you can either choose “Off” or “On” for “always_populate_raw_post_data”. These are different to “-1”. You need to edit the file by hand in “/usr/lib/php.ini”

Hope this helps someone in the future. :slight_smile:

@davidclark52 - This was driving me nuts for a minute there, and you just saved me oodles of time troubleshooting here. Thank you.

In my WHM what’s interesting is that it showed the default was already set to -1, although it was crossed out, so I simply hit the “click to edit” button (which revealed the existing -1 value) and scrolled to the bottom and hit save… and then checked the newly output php.ini file for accruacy (it was correct now), and everything is working. Kind of an interesting bug.