Plugsin missing

Your software
My Mautic version is: 4.4.4
My PHP version is: 7.4.33
My Database type and version is: 10.5.18-MariaDB-0+deb11u1

Your problem
My problem is: Mautic installed by using composer. The plugins are missing, but not all. The user’s avatar is also missing.

These errors are showing in the log:

Today’s Mautic error log is empty. Check server error log for error messages Mautic didn’t have a chance to catch.

Steps I have tried to fix the problem:

It seems to me this is related to files and folder permissions or path.
I checked the permissions. Inside the docroot directory, this was done at installation:

cd docroot 
sudo -u www-data sh 
find . -type f -not -perm 644 -exec chmod 644 {} +
find . -type d -not -perm 755 -exec chmod 755 {} +
chmod -R g+w app/config/

The current permission state of the directory:

drwxr-xr-x  2 vincent  vincent    4096  1 mars  19:18 app
-rw-r--r--  1 vincent  vincent      54  1 mars  19:18 autoload.php
drwxr-xr-x  2 www-data www-data   4096  1 mars  19:18 bin
-rw-r--r--  1 vincent  vincent    4035  1 mars  19:19 composer.json
-rw-r--r--  1 vincent  vincent  591700  1 mars  19:16 composer.lock
drwxr-xr-x  8 www-data www-data   4096  1 mars  19:21 docroot
-rw-r--r--  1 vincent  vincent    1937  1 mars  19:18 Gruntfile.js
-rw-r--r--  1 vincent  vincent     422  1 mars  19:19 package.json
-rw-r--r--  1 vincent  vincent  153675  1 mars  19:18 package-lock.json
-rw-r--r--  1 vincent  vincent    6276 31 janv. 15:37
drwxr-xr-x 76 vincent  vincent    4096  1 mars  19:18 vendor

In System Info > Folder & File Permissions: all is writeable (green color)

Thank you for any suggestion.

Can you click on the search bar where it reads show all plugins at top left then unselect what might be there.

Hi tobsowo, I tried. It does not solve the problem. in fact, there are only 3 plugins there, of which only Grape JS could be selected. The two other plugins have grey icons. thank you for your suggestion.

I would like to ask one more question regarding the permissions of folders and files. Is it correct to have the folder vendor and app not belonging to www-data user and group. I’m having them under my own user name and group.

I have the challenge with 4.4.6 recently and I tried what I mentioned earlier and it worked probably I forget all I did.

Don’t much much technical experience and may not be able to answer this.

I figured it out. It was due to a nginx configuration

location ~ /(addons|plugins)/ { deny all; }

I don’t remember where I copied this line from. I comment it, clear cache, and all plugins are there.

For the user’s missing icon: the problem was solved when I upgraded to 4.4.7.

Hi Mikew, although you deleted the comment, I saw it in the notification email. Do you mean it is not safe to uncomment this line? I have to admit that my knowledge (nginx) in very limited and was not aware that it was the sensitive. Thanks.

Hi - no this is how it should be, it was my mistake on the comment, I did not read my conf file correctly.

I can highly recommend linuxbabe nginx conf for Mautic, it can be found here.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.