Issue On Importing Plugins in mautic 4.4.5

Mautic 4.4.5
My PHP version is : 8.0.27

My problem is : Hello, I want to install thecustom objects plugin in my mautic. I downloaded the github repository : GitHub - acquia/mc-cs-plugin-custom-objects: Mautic plugin adding Custom Objects feature
I exported it in my plugin directory and I changed the name as it said in the composer file.
The problem is that when I want to Install the plugin by clicking on “Install/Update plugins”, it return that no plugin had been installed and no plugin had been udated.

Does anyone know what is the reason of this issue ?

Steps I have tried to fix the problem :

Did you clear the cache and make sure permissions are right after the download ?

Thanky you for your resopnse, how can i do that?

Well, here is a short tutorial:

I tried to clear the cache but I have an Error :

Can you plz ellaborate what exactly you did?
Also: which user runs Mautic on your server?

I ran the comand rm -rf var/cache/* as root user.

I did mention that in my blogpost, but It makes sense to read the whole thing:

This is usually a good advise, but running the command above can go terribly wrong. And this is because of the permissions. It’s super important that the right “person” is issuing the commands. Let me explain…

And then I’m mentioning the part how to identify the right user and warmup the cache:

Once your permissions are already messed up, you can any time fix it. Go to your Mautic folder, and:

sudo -u www-data php /var/www/html/mautic/app/console cache:clear

find . -type f -not -perm 644 -exec chmod 644 {} +
find . -type d -not -perm 755 -exec chmod 755 {} +
chmod -R g+w var/cache/ var/logs/ app/config/
chmod -R g+w media/files/ media/images/ translations/
rm -rf var/cache/*