Mautic Community Forums

Problem setting language

Hello,



I’ve installed Mautic in our own server, on a subdomain. When I try do change language (in profile or system defaults settings), I get the following error: “mautic.core.could.not.set.language”



I have php 5.3.29 PHP version.



Could you please help?



Thank you

Hello,

I’ve installed Mautic in our own server, on a subdomain. When I try do change language (in profile or system defaults settings), I get the following error: “mautic.core.could.not.set.language”

I have php 5.3.29 PHP version.

Could you please help?

Thank you

During installation I got these:

•	You should have PCRE version 8.0 or later installed. Your environment has version 7.8 installed. It is suggested you update your PCRE installation.
•	The date.timezone setting is not set in your PHP configuration. Mautic has set the default timezone to 'UTC' but we suggest setting this in your PHP configuration.

Should I work on these? Any suggestion’s welcome.

Hi:

If possible you should try to get a slightly newer version of PHP. 5.3 is supported by Mautic, but its not supported by PHP anymore! (readmore here: https://www.mautic.org/community/index.php/586-php-version)

The php timezone error is easily solved with a quick edit to php.ini. Read more about that here: http://www.inmotionhosting.com/support/website/php/setting-the-timezone-for-php-in-the-phpini-file

The PCRE error is probably due to the old php version as well, so hopefully that will be fixed on a newer version of PHP. If not you’ll have to manually fix it (http://stackoverflow.com/questions/12212079/pcre-librairies-version-is-too-old)

Thank you Chad, I’ve upgraded PHP and I’ve solved with this: https://www.mautic.org/community/index.php/72-installer-page-is-blank

Hi,
I have problem set czech language on mautic 1.2.3. own server/ subdomain /PHP 5.6
The same error like first post “mautic.core.could.not.set.language”

Check the PHP error log and the Mautic logs (app/logs dir) if there is some error message. Also check the permission and the owner of the /translations dir. Maybe Mautic doesn’t have the permission to write there.

I set 777 for all folders and files = the same problem
mautic error:
[2016-01-17 00:07:41] mautic.WARNING: Command doctrine:migrations:version exited with status code 255 [] []
[2016-01-17 00:07:41] mautic.ERROR: PDOException: SQLSTATE[HY000] [2002] Can’t connect to local MySQL server through socket ‘/tmp/mysql.sock’ (2) (uncaught exception) at /data/web/virtuals/53728/virtual/www/domains/mautic.solna-lampa.cz/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php line 40 while running console command doctrine:migrations:version [] []

That’s 3 days old error, that won’t be related. I’ve tested it on my Mautic instance. I’ve had the Czech already downloaded (mimochodem, ahoj :wink: ) so I removed the translations/cs directory, went to Mautic configuration, selected Czech again, saved. TBH, it did not download Czech for the first time, but it worked for the second time. The cache had to be cleared after I deleted the language dir I guess.

Hi there, where I can download Czech translation file please? I have the same issue with system language settings.

Language files are downloaded and concatenated by a script somewhere at mautic.org from https://www.transifex.com/mautic/mautic/. I don’t know the URL address for the concatenated files. The simplest solution would be to fix the language file download while you select it in the configuration and save. There must be a server setting or a permission problem preventing it to work as it should.

I have the same problem. We tried for many, the PHP update after changing permissions of folders and files … Nothing helps.

PHP 5.6.17
error: message: "mautic.core.could.not.set.language"
error log:

"[01/24/2016 11:55:24] mautic.NOTICE: PHP Notice: SessionHandler :: gc (): ps_files_cleanup_dir: opendir (/ var / lib / php5) failed: Permission denied (13) - in file / var / www / svetzitrka.cz / subdomains / MTC / app / cache / prod / classes.php - at line 423 [] []"

Perhaps this is related to some approaches, but do not know where to look. You Metz also something to do with the absence of flags, see. screen?

Try to place:

echo "<pre>";var_dump($fetchLanguage['error']);die("</pre>");

to this line:

https://github.com/mautic/mautic/blob/staging/app/bundles/CoreBundle/EventListener/ConfigSubscriber.php#L64

I can see the error reporting there isn’t finished. It should tell you what the error message is.

We carried out the treatment, but when applying CZ language in setting it freezes on the “Please wait …”
Error message never does not list any. Neither PHP nor Mautic

Do you know how to work with Chrome Dev Tools? If so, open the request sent after save and see the message in its body.

Even when updated to version 1.2.3 I continued with language configuration problem .So, I discovered a group on face only dedicated to Mautic Brazil.
Here is the solution that Igor Almeida found, and it worked:

Summing up:

  1. Download this file: http://s000.tinyupload.com/?file_id=08421274438124417591 (avaliable to Portuguese Brazil, only).

  2. Unzip in the folder / translations

  3. Use an FTP and delete the contents of the / app / cache
    note: not all files were deleted, in my case, but it worked.

  4. Clean the Browse cache (browser), too.

  5. Log in Mautic

  6. Make the change of language in the settings

  7. Change the language setting in the menu “Account”.

Note: is the directory where you installed the Mautic
Put the whole pt_BR folder inside the extracted folder … / translations

It is crucial to clear the cache.

I have resolved this problem.

Problem is caused in file LanguageHelper.php. This script is used to download language zip file. It loads URL and checks if server HTTP response is “200 OK”. If not, it fails. This is cause of (at least my) problem. Server isn’t responding with “200 OK”, but with “303” - a redirection. Script fails to recognize a redirection and automatically fails.

A patch for this problem is simple - just add this code and everything is going to work fine. Only thing I did was to follow redirection link, check again if it’s valid and pass new URL to the rest of script.

@myflower would you mind make it a pull request so it would be part of the Mautic’s core and the hacks won’t be necessary?

@escopecz I’m sorry, but what’s a pull request? :slight_smile:

@myflower good question. It’s a process which all Mautic developers to to suggest code changes to Mautic code base (or any other open source software on GitHub). Try to google more details about it. Here is how to set up the local development environment for it:

https://github.com/mautic/mautic#how-to-test-a-pull-request