Scheduled email issue with Anacron + SendGrid

PHP Version 7.4.5
MySQL 5.7
Mautic v3.3.2
Email API: SendGrid

My problem is:

Some emails are sent (confirmation, automatically - for instance) but when a wait condition is added for a campaign, seems that it’s not adding this email to the loop and nothing is showing up.

These errors are showing in the log:
no error in the logs :frowning:

Steps I have tried to fix the problem:

First, I set up my Anacron tab with the following info, starting:

@hourly 0 mautic_leadlists php -f /srv/data/web/vhosts/ mautic:leadlists:update
@hourly 0 mautic_segments php -f /srv/data/web/vhosts/ mautic:segments:update
@hourly 0 mautic_campaigns_update php -f /srv/data/web/vhosts/ mautic:campaigns:update
@hourly 0 mautic_campaigns_trigger php -f /srv/data/web/vhosts/ mautic:campaigns:trigger
@hourly 0 mautic_campaigns_execute php -f /srv/data/web/vhosts/ mautic:campaigns:execute
@hourly 0 mautic_emails_send php -f /srv/data/web/vhosts/ mautic:emails:send
@hourly 0 mautic_broadcast php -f /srv/data/web/vhosts/ mautic:broadcast:send
@daily 0 mautic_fetch php -f /srv/data/web/vhosts/ mautic:email:fetch
@daily 0 mautic_import php -f /srv/data/web/vhosts/ mautic:import
@daily 0 mautic_social php -f /srv/data/web/vhosts/ mautic:social:monitoring
@weekly 0 mautic_maxmind_dl php -f /srv/data/web/vhosts/ mautic:iplookup:download
@weekly 0 mautic_maxmind_donotsell php -f /srv/data/web/vhosts/ mautic:donotsell:download
@weekly 0 mautic_maxmind php -f /srv/data/web/vhosts/ mautic:max-mind:purge

Please note that there is no documentation on the Internet(s) about anacron + Mautic so I think this is useful as well to share it here!

My test form is live on

To fix this: I tried to add another cronjob with lead lists but same!

The screenshot showing that there is no upcoming email > CleanShot 2021-04-19 at 11.26.03 · CleanShot Cloud
Despite the screenshot with all actions and in pending > CleanShot 2021-04-19 at 11.27.03 · CleanShot Cloud

Thank you in advance !


  • Test sent email are working but not any campaign is actually sent even if emails and campaigns are being published. There are no error log on this… Any thought?

Thank you.

I tried to find issues on Mautic docs, nothing to add.

  • No error logs in Apache either in Mautic instance. Maybe this is a hosting problem but can’t find how/why.

I will drop Mautic as a b2b tool as it’s not giving me sufficient trust to use it for a growing business and use an HubSpot or ActiveCampaign. I see this as the limit of Open Source, good learnings for my students though!

I would be happy to share my 20 yo digital marketing expertises. Find me @phb on Twitter or Slack.

What is the purpose of using anacron @phb?

I did not select this on purpose. This is what the hosting provider use on their Shared Web Hosting.

I would suggest that you move Mautic to a VPS.

1 Like