Secondary Campaigns Not Working

My Mautic version is: 4.0.1
My PHP version is: 7.4
My Database type and version is: MariaDB 10.4

My problem is:
I created a double opt-in campaign by triggering when a contact is added. It will check if their tag is verified and if not it sends them an email. It then checks if they click the email verification link. After this it adds the verified tag. This campaign works perfectly. However, after this I have set up another campaign to send them another email. This time it checks if they are in the Email Verified segment which I set up to add them to this segment if they have the verified tag. From there it sends the email. The contact goes through the campaign, when I run the cron jobs manually I can see it processing the contact when trigger cron is run, I see the email has 1 in queue, but it doesn’t add the email to the spool folder. I also set this campaign to run first instead of the double optin campaign and it fires fine, something about having a second campaign is messing with it?

These errors are showing in the log:

Steps I have tried to fix the problem:
Deleting the campaigns

Hi, check your frequency settings. Settings - email settings - frequency
What happened is that this email is postponed as too many marketing emails were sent already for this day. You can release the mail with
console mautic:messages:send
Once the settings are altered.

More info to this:

1 Like

You are amazing sir! That’s very odd, it’s default is 0 so I figured it was just for unlimited, but I guess it doesn’t work that way. It’s weird that I could keep retriggering the campaigns and it would send again, but I guess the frequency is per user? The documentation made it sound like it is, so if this is in fact based on a user basis, then I’d say 3-5 per user would probably be max. Also, if they move to queue, does this mean the next day they will be processed? Really appreciate the help!

Yes it used to be unlimited, but something happened to Mautic’s soul on 4.0.0 and this message queue issue started to pop up. Just set it as it’s comfortable for you, and it will be okay.

Awesome, thanks again!