SendGrid API Bridge Error in Mautic 5.0.3

Your software
My Mautic version is: 5.0.3
My PHP version is: 8.1.27
My Database type and version is: mysql Ver 15.1 Distrib 10.3.39-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

Your problem
My problem is: I upgraded mautic from 4.4.10 to 5.0.3 after that new feature is showing EMAIL DSN.

I tried install composer require symfony/sendgrid-mailer but not sure where it is getting installed.

Please guide the correct path to install this sendgrid-mailer.

These errors are showing in the log:
Unable to send emails via “sendgrid” as the bridge is not installed; try running “composer require symfony/sendgrid-mailer”.

1 Like

You’ll need to clear your cache after requiring a transport. You can do this using the Command Line Interface:


There were a couple times this didn’t work and we had to manually clear cache.

Having the same issue, having done this on my A2hosting cpanel - Terminal, I received this error:

bash:bin/console: Permision denied

Sounds like a permission issue
chmod a+x [path/to/mautic/]bin/console

Or, invoke it using PHP
php [path/to/mautic/]bin/console mautic:cache:clear

@marcus42 thanks for the speedy reply!
(brave newbie here)
I gave that a roll, and I think it worked. I got no response from Terminal other then a fresh prompt line.

Went back into Email settings and received the same error.
Perhaps you can help me trouble shoot this too!
My Mautic version: v5.0.4
My PHP Version: 8.1.27


.env File:

No output == success most likely.

Regarding your second issue;
I would get rid of the “sengrid+” in the “sendgrid+smtp” and give it a try.

Hi @marcus42 ,
Thanks for continuing with me here… when I try that I get this error: