Mautic 5 and Amazon SES Integration Error

Your software
My Mautic version is: v5.0.1
My PHP version is: 8.1

Your problem

Upon upgrading, I attempted to integrate Mautic with Amazon SES, following the installation of “symfony/amazon-mailer.” However, I encountered the following error message: “The ‘ses+smtp’ scheme is not supported.”

I would appreciate your guidance on how to successfully set up Amazon SES with Mautic, specifically addressing the mentioned error. Additionally, I am seeking advice on how to handle the message limit on Amazon SES, given the constraints on the number of messages allowed per second.

Any insights or step-by-step instructions you could provide to resolve these issues would be highly valuable. Thank you in advance for your time and assistance.

Best regards,

Hi there!. any luck with this issue?. I do have the same problem with ses+api and sendgrid+api. both symphony packages installed via composer.

Hi, here is my tutorial, that covers it:

Regarding restricting number of messages - I don’t have a tutorial yet, for that you would probably need to use queueing, and this tutorial doesn’t have it yet.

1 Like

Thanks, but clearing the cache is what made it work. after installing the symfony package, it wasnt really detecting the amazon mailer untill I manullay clear the var/cache.
btw I am trying to make the amazon SQS work with no luck

I have tried everything in this thread and am still getting the same error message where:
“Unable to send emails via “ses” as the bridge is not installed; try running “composer require symfony/amazon-mailer”.”

And did you try?

And did you try what exactly? If you’re referring to the command in the error message, yes haha. Definitely tried that. Composer has installed the necessary package. It’s like it’s not recognizing it for some reason.

Coll. Did you install at docroot? Right outside the vendor folder?

Hi, I followed your tutorial. Thank you for your time. I´m using Ngix with Hestia Panel. I have installed mautic in /var/www/mautic where I run " composer require symfony/amazon-mailer". I clear the var/cache, however, I´m still receiving the message: "Unable to send emails via “ses” as the bridge is not installed; try running “composer require symfony/amazon-mailer” in Mautic configuration. Any idea what could be done to solve the problem? Ty in advance! :slight_smile:

Hi! when trying this mailer, the sending test fails with an error 500. But there is no trace of the error in Mautic logs…:thinking:

Hi,

I have develop a plugin to Mautic 5 to Amazon SES.

You can try in: GitHub - pabloveintimilla/mautic-amazon-ses: Mautic 5 plugin, provides Amazon SES as an email transport and callback to process bounces

Regards!

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.