Mautic Community Forums

Setting up Mailhog with Docker Toolbox

Hi,

The issue there is that you are already using the port 2025 for something else (maybe another instance of the same image?)

Try running docker ps to see what you have running.

1 Like

Not sure if this helps, but I’m using DDEV for local Mautic development. It includes PHP/MySQL/PHPMyAdmin/Mailhog out of the box with Docker images (see “Email Capture and Review” for details on the Mailhog integration). Makes it a breeze to get things set up properly. :slight_smile:

You can read more about using Mautic in DDEV here: https://www.mautic.org/blog/developer/local-mautic-development-with-ddev

$ docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
52c575c5ea64 drud/ddev-ssh-agent:v1.13.0-built “/entry.sh ssh-agent” 16 seconds ago Up 13 seconds (healthy) ddev-ssh-agent
fdaa026eaa7c phpmyadmin/phpmyadmin:5 “/docker-entrypoint.…” 19 hours ago Up 10 seconds 0.0.0.0:32770->80/tcp ddev-mautic-dba
27bf72b52871 drud/ddev-webserver:v1.13.1-mautic-built “/start.sh” 19 hours ago Up 10 seconds (healthy) 8025/tcp, 192.168.99.100:32769->80/tcp, 192.168.99.100:32768->443/tcp ddev-mautic-web
1d2af90dd8ca drud/ddev-dbserver-mariadb-10.2:v1.13.0-mautic-built “/docker-entrypoint.…” 19 hours ago Up 10 seconds (healthy) 192.168.99.100:32771->3306/tcp ddev-mautic-db
8976bb41ce5d drud/ddev-router:v1.13.0 “/app/docker-entrypo…” 19 hours ago Up 8 seconds (healthy) 192.168.99.100:80->80/tcp, 192.168.99.100:443->443/tcp, 192.168.99.100:8025->8025/tcp, 192.168.99.100:8036->8036/tcp ddev-router

ty I’m checking ‘for details on the Mailhog integration’ maybe I missed some step

Try ddev describe (https://ddev.readthedocs.io/en/latest/users/cli-usage/#partial-bundled-tools-list) and it will show you how to access Mailhog :slight_smile:

1 Like

Apparently HTTPS doesn’t work in your case. Try with http:// instead of https://. For local development you don’t really need HTTPS (as it’s not publicly available in any way), but if you still want to fix HTTPS, you might want to try to run the command mkcert -install again. But if you can’t fix it easily, it might be a lot of work to get it working properly, so it’s probably easier to just use http:// for now. :slight_smile:

1 Like

$ mkcert -install
Using the local CA at “C:\Users\Alexei\AppData\Local\mkcert” :sparkles:
The local CA is already installed in the system trust store! :+1:
Note: Firefox support is not available on your platform. :information_source:

maybe it is due to the browser, i’m currently using Brave

btw, do you know where there is more information related to enabling the feature
image
?

Just make sure to select “PHP Mail” in Configuration > Email Settings and all emails will automatically go to Mailhog :+1: you should be able to see them in Mailhog then


I set it up before, I can even receive emails in mailhog, but if I open email, I can’t see the feature (read) enabled in mautic

Not sure how to help you with that, sorry. Haven’t tested that case myself

Ensure that when opening the email you do so in an incognito window. Opens from a browser where you have a session logged into Mautic will not be tracked by default.

I want to fix the https, could you recommend me some post or steps to follow?