Mautic Community Forums

The page isn't redirecting properly

After trying to upgrade to 1.2.4 I can’t login/load mautic in the browser and all the error messages are orientated around “The page isn’t redirecting properly”. I’m wondering if the culprit is Cloudflare/.htacess and/or the local.php config file.



When I tried to turn-off Cloudflare and access the site via http instead of https, I still had the same problem, so I wonder if the site address is stored anywhere else other than local.php. A quick look at the database didn’t suggest any config type entries you get in WordPress.



The command line entries seem fine but running app/console router:debug suggests everything is running from https. Maybe turning that off might help, but I don’t know how to change that setting. Finally, I haven’t done anything with the cache yet, maybe that’s the next thing to try?



Does anyone have any ideas?

After trying to upgrade to 1.2.4 I can’t login/load mautic in the browser and all the error messages are orientated around “The page isn’t redirecting properly”. I’m wondering if the culprit is Cloudflare/.htacess and/or the local.php config file.

When I tried to turn-off Cloudflare and access the site via http instead of https, I still had the same problem, so I wonder if the site address is stored anywhere else other than local.php. A quick look at the database didn’t suggest any config type entries you get in WordPress.

The command line entries seem fine but running app/console router:debug suggests everything is running from https. Maybe turning that off might help, but I don’t know how to change that setting. Finally, I haven’t done anything with the cache yet, maybe that’s the next thing to try?

Does anyone have any ideas?

Try to clear the cache and check your server config to make the https the main one.

Turning off all the https stuff and renaming/deleting the app/cache folder did the trick - thanks!