Mautic Community Forums

Thought Upgrade issues was fixed?

Just did a clean install of 2.15.1 and everything is just fine…saw the upgrade 2.15.2 and tried to upgrade from the desktop/bell and same as always…never finishes and craps up the install.

Thought they said it was fixed in this version…personally I don’t think I ever had a software this bad at upgrades.

Back to a dump and clean install.

Maybe some one will post a very easy way to manually do an upgrade.

Thanks

2.15.2 has upgrade issue. Fixed it 2.15.3 released next week, I hope.

You can upgrade also by console.
Just download upgrade.php


And run php upgrade.php

Ok will try to upgrade again when 2.15.3 comes out and see if it works…hope so…

Thanks

1 Like

Was so hopeful the update ( 2.15.3) would work right out off the bell…but

Got pass " Moving Package" this time"…but now craps out on: “Clearing Application Cache”

Just hangs and goes nowhere…Bummer

Downloading Package Success
Extracting Package Success
Moving Package Contents Success
Clearing Application Cache In Progress

This happened to me too. I ended up getting it working by ssh’ing into the box, clearing the cache, and running doctrine updates. Now it works like a charm!

Hey Gabe,

My update is currently hanging on ‘Clearing Application Cache’ and I am unsure of the steps to take to rectify the situation as per your instructions.

I have gone into /mautic/app/cache and tried deleting the ‘prod’ folder and the whole of the ‘cache’ folder.

What are the doctrine updates and what commands would I use to execute them?

Many thanks!

Ok guys, if you have access to SSH for your Mautic installation then simply follow this guide to update simply and effectively to the lastest instance (2.15.3) of Mautic;

https://www.mautic.org/docs/en/tips/update-failed.html

I’m aware that this is a post about how to recover from a failed update, however it contans step by step commands to execute via terminal as it seems a few people are still having issues with the online updater or database errors.

Thank you for all your help so far!

How long is it hanging? Mine took an age to get past this phase but eventually it did move on. If it fails, follow the directions in the documentation regarding a failed upgrade (running at command line) and you should be good to go!

Yup logged out and back in the next day and the final part of the upgrade must of finished…looks fine now…hope the future upgrades work with no issues or hoops…

1 Like

Yep, for me it was the stuff in steps 3 and 4 of the the link provided by @masidus that worked. I found out about it from this Github comment.

Thought it worked but no…messed up the forms tab…would not work.

Found this helper video also…https://www.youtube.com/watch?v=cIG9CBzxg5w

Clearing the app cache per upgrade request can take quite a bit of time. Your PHP execution times are probably set too low. Default is most likely 30 seconds, which is why the process seems like it hangs. In reality, PHP simply shuts down as it has been running for 30 seconds. Try setting this to something more liberal, like 4 or 5 minutes.

1 Like

Hi guys, I’ve just uploaded a “Mautic Update How-To” on mauteam.org
https://mauteam.org/mautic/mautic-admins/mautic-update-how-to-dont-click-that-button/
Hope it’s useful!

1 Like

Yup did a fresh reinstall of 12.15.1 and upped PHP execution time to 240 sec…hit the bell and did the upgrade …worked perfect this time…Thanks everyone.

1 Like