Trying to update Mautic but get this error

I am trying to update Mautic from 4.2.1 to 4.2.2 but get this error instead … can anyone explain what it mean and what needed to be done to fix it …

Thank you

composer update
Loading composer repositories with package information
Updating dependencies
Info from #StandWithUkraine
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires mautic/core-lib ^4.0, it is satisfiable by mautic/core-lib[4.0.0-alpha1, ..., 4.x-dev] from composer repo ( but mautic/core-lib[dev-master] from path repo (app) has higher repository priority. The packages with higher priority do not match your constraint and are therefore not installable. See for details and assistance.

Check this guide to update:

This won’t work … when I try this … this is the result I get

You have Composer updates enabled. This means that you can only update Mautic through the ‘composer update’ command. Read more in the documentation: How to switch to Composer | Mautic

Is this a composer based install?

If it is maybe instructions on this page:

can help (under Update Mautic Core), if not try setting option: composer_updates to 0 in app/config/local.php and run the update commands from the first link again.

Yes as I mentioned about the composer command in my first post … It a composer based installation Mautic