Mautic Community Forums

Unable to change site URL

Dear all, recently i installed mautic on an http url and all is great.



I then decided to install an SSL cert, although is working (on the SSL site via https://mydomain.com) despite updating the URL under Settings -> Configuration -> General Settings -> Site URL the value entered there is not remembered (always reverts to http://mydomain.com).



Is there anywhere in the database or other settings file where i can manually change this?

Dear all, recently i installed mautic on an http url and all is great.

I then decided to install an SSL cert, although is working (on the SSL site via https://mydomain.com) despite updating the URL under Settings -> Configuration -> General Settings -> Site URL the value entered there is not remembered (always reverts to http://mydomain.com).

Is there anywhere in the database or other settings file where i can manually change this?

I am having the exact same issue, installed an ssl certificate, changed my site url in configuration to https://www in mautic, I ‘Apply’ and ‘Save and Close’, as soon as I go to another page and go back to configuration, it has reverted in the site url in configuration back to http://

This is causing issues with my forms not submitting now. I have clicked the refresh button on forms which updated my forms url when viewing ‘manual copy’ to https://www, also updated my mautic scripts in my files to https:/www. When view the form page, it’s accessing the mautic url as https://www. However my forms don’t submit due to the actual configuration page stating the url has reverted to http://

In my case the problem was solved by setting Trusted proxies.
My setup is browser-https->reverse proxy-http->mautic.
In that cause I had to settings->configuration->trusted proxies and fill in the ip address of your proxy.
If you don’t know or if you’re proxy changes(behind AWS ELB) then you can set it to 0.0.0.0/0
After the change the generated urls now uses https.

I’m having the same problem.

@MxyzptlkFishStix I know what you’re trying to say. Mautic has a bug that requires SAML settings to have vaules. But this is a different problem. The problem is Mautic generates http urls even my site_url is https.