Mautic Community Forums

Unable to save SSO configuration with updated FederationMetadata.xml

Your software
My Mautic version is: v2.15.3
My PHP version is: 7.0.33-0ubuntu0.16.04.7

Your problem
My problem is: SSO stoped working. This has happened before where mautic redirects to the login page and fails to authenticate on submit. Previous way to resolve this was to update the SSO settings. In the current version of Mautic this is not possible as updating the FederationMetadata.xml results in a 500 Internal Server Error, when saving the settings.

These errors are showing in the log:

[2019-12-18 14:58:16] mautic.CRITICAL: Uncaught PHP Exception Exception: "Serialization of 'Symfony\Component\HttpFoundation\File\UploadedFile' is not allowed" at /srv/example.com/html/app/bundles/CoreBundle/Doctrine/Type/ArrayType.php line 43 {"exception":"[object] (Exception(code: 0): Serialization of 'Symfony\\Component\\HttpFoundation\\File\\UploadedFile' is not allowed at /srv/example.com/html/app/bundles/CoreBundle/Doctrine/Type/ArrayType.php:43)"} []

Steps I have tried to fix the problem:

  1. Tried clearing cache
  2. Deleting the setting, save, re-edit page with new setting - saving fails.

Regards

Hi @nish.joseph and welcome to the Mautic Community Forums! Thanks for bringing the conversation over here from Slack :mautibot:

From what I can see you have two issues here:

  1. SSO failing to authenticate on submit
  2. Unable to update the SSO settings

Regarding #2, I found this github thread: https://github.com/mautic/mautic/issues/7294 which suggests this Pull Request might fix the problem: https://github.com/mautic/mautic/pull/7305.

Maybe if you can try to apply this PR, and see if it fixes the problem? If so, please report it as a successful test by going to the PR, clicking on ‘files changed’, click ‘review changes’, add a comment and select approve changes.

If you need help applying the PR let me know :slight_smile:

Hi @rcheesley,
Thank you for you help. Yes the PR worked, I will comment on the PR too. Hopefully it get merged.

The authentication now works too. I am not entirely sure why this issues pop’s up from time to time.

Cheers!

1 Like

Awesome! Great to hear and thanks for commenting on the PR, hopefully we can get it merged into the next release after M3 :slight_smile:

Some weeks back, we experienced the same issue as the OP while integrating Mautic with SAASPASS for 2FA. Using the pull request you linked above @rcheesley we were able to work around the issue and successfully connect Mautic with the SAML provider, and redirect the login page to the SSO challenge.

1 Like