Mautic Community Forums

Update 2.2.1 Error, did it update?

Hi All,



I’ve upgraded via the script to 2.2.1, but Im still getting the little notification that says I need to upgrade.



So I checked the logs…



Im getting a bunch of issues…

Code:
mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentPropertyAccessExceptionInvalidArgumentException: "Expected argument of type "MauticStageBundleEntityStage", "NULL" given" at /opt/bitnami/apache2/htdocs/mautic/vendor/symfony/property-access/PropertyAccessor.php line 254
Code:
mautic.CRITICAL: Uncaught PHP Exception Twig_Error_Loader: "The "/opt/bitnami/apache2/htdocs/mautic/vendor/doctrine/doctrine-bundle/Resources/views" directory does not exist." at /opt/bitnami/apache2/htdocs/mautic/vendor/twig/twig/lib/Twig/Loader/Filesystem.php line 94 {"exception":"[object] (Twig_Error_Loader(code: 0): The "/opt/bitnami/apache2/htdocs/mautic/vendor/doctrine/doctrine-bundle/Resources/views" directory does not exist. at /opt/bitnami/apache2/htdocs/mautic/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:94)"} []
Code:
mautic.ERROR: Deprecation: The alias option of the form.type_extension tag of service "fos_rest.form.extension.csrf_disable" is deprecated since version 2.8 and will be removed in 3.0. Use the extended_type option instead. - in file /opt/bitnami/apache2/htdocs/mautic/vendor/symfony/framework-bundle/DependencyInjection/Compiler/FormPass.php - at line 67 [] []

How can I tell if the upgrade actually worked?

Thanks,
John

Hi All,

I’ve upgraded via the script to 2.2.1, but Im still getting the little notification that says I need to upgrade.

So I checked the logs…

Im getting a bunch of issues…

mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentPropertyAccessExceptionInvalidArgumentException: "Expected argument of type "MauticStageBundleEntityStage", "NULL" given" at /opt/bitnami/apache2/htdocs/mautic/vendor/symfony/property-access/PropertyAccessor.php line 254
mautic.CRITICAL: Uncaught PHP Exception Twig_Error_Loader: "The "/opt/bitnami/apache2/htdocs/mautic/vendor/doctrine/doctrine-bundle/Resources/views" directory does not exist." at /opt/bitnami/apache2/htdocs/mautic/vendor/twig/twig/lib/Twig/Loader/Filesystem.php line 94 {"exception":"[object] (Twig_Error_Loader(code: 0): The "/opt/bitnami/apache2/htdocs/mautic/vendor/doctrine/doctrine-bundle/Resources/views" directory does not exist. at /opt/bitnami/apache2/htdocs/mautic/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:94)"} []
mautic.ERROR: Deprecation: The alias option of the form.type_extension tag of service "fos_rest.form.extension.csrf_disable" is deprecated since version 2.8 and will be removed in 3.0. Use the extended_type option instead. - in file /opt/bitnami/apache2/htdocs/mautic/vendor/symfony/framework-bundle/DependencyInjection/Compiler/FormPass.php - at line 67 [] []

How can I tell if the upgrade actually worked?

Thanks,
John

It sounds like the update did not complete. I wrote up how I fixed it on my system:

https://www.mautic.org/community/index.php/conversation/post/16500