Mautic Community Forums

Upgrade from 3.3.3 via 3.3.4 to 4.0.0 broke installation

Mautic 3.3.3 → 3.3.4 → 4.0.0
My PHP version is : 7.4
My MySQL/MariaDB version is (delete as applicable): mysql Ver 15.1 Distrib 10.3.31-MariaDB

Updating/Installing Errors
I am (delete as applicable): Updating
Upgrading/installing via (delete as applicable) : Command Line

These errors are showing in the installer : None

These errors are showing in the Mautic log :

[2021-09-01 10:10:48] mautic.ERROR: Symfony\Component\Filesystem\Exception\IOException: Cannot rename "/tmp/UrlGenerator.phpPDIDgu" to "/var/log/mautic/cache/prod/UrlGenerator.php". - in file /var/www/mautic/vendor/symfony/filesystem/Filesystem.php - at line 290 [] []

Your problem
My problem is : Upgrade from 3.3.3 says all is good i am now running 3.3.4! \o/
go to webpage: everything is broken /o\

“The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.”

Oh no! i am system administrator!

Try to upgrade from there to 4.0.0 because no one told me i would have to upgrade to 3.3.4 first and maybe it’s just an intermediary

Upgrade from 3.3.4 says all is good i am now running 4.0.0! \o/
Go to page: everything is borken, same error message. /o\

Steps I have tried to fix the problem : Pull hair, look into logs, despair.

While trying to debug, i realize i am not able to find the file in which the passwords for the DB are set

app/config/config.php and app/config/config_prod.php are no longer containing it… But was it ever there, or did the installer replace my config file?

It seems that because i am using Nginx i have problems with some rewrites that aren’t consistent with how Mautic 3.3.3 was working. The documentation for using Nginx in conjunction with Mautic being too sparse and none of it being officially supported by Mautic (seemingly), there is not way for me to fix this in a way i am comfortable with.

My setup is not allowing me to run appache2 as it would jeopardize the configuration of too many other projects. So until there is a proper documentation for nginx, i simply have to retire my mautic and find some other tool.

Correction: A fresh install of 4.0.0 works like a charm. So it is not the nginx config. I haven’t been able to restore with a database backup. And since i was just getting started i figure it will take me about the same amount of time to redo my work than ti would trying to figure out what is going wrong with my DB.

Essentially, the good news is that i am up and running again \o/

app/config/local.php

try running the console cache:clear command and then refresh the page

1 Like

i managed to botch my backup of the DB during my attempts, so I can’t try that :frowning: but i highly appreciate your feedback regardless, thank you! i take note for next time around :slight_smile:

Our install seemed to survive, but it killed our zapier integration. Does anybody have Zapier running with 4.0? Hints?