Mautic Community Forums

Upgrade to 2.11.0 Email Error

Hi there,



I just upgraded to new version v2.11.0 and now I get this error when trying to select email channel and I cant create or go any further with emails.



Error message is “The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

System administrators, check server logs for errors.”



Here’s a copy of the log error that I think relates.



[2017-12-01 11:16:01] mautic.ERROR: DoctrineDBALExceptionInvalidFieldNameException: An exception occurred while executing ‘SELECT e0_.is_published AS is_published_0, e0_.date_added AS date_added_1, e0_.created_by AS created_by_2, e0_.created_by_user AS created_by_user_3, e0_.date_modified AS date_modified_4, e0_.modified_by AS modified_by_5, e0_.modified_by_user AS modified_by_user_6, e0_.checked_out AS checked_out_7, e0_.checked_out_by AS checked_out_by_8, e0_.checked_out_by_user AS checked_out_by_user_9, e0_.id AS id_10, e0_.name AS name_11, e0_.description AS description_12, e0_.subject AS subject_13, e0_.from_address AS from_address_14, e0_.from_name AS from_name_15, e0_.reply_to_address AS reply_to_address_16, e0_.bcc_address AS bcc_address_17, e0_.template AS template_18, e0_.content AS content_19, e0_.utm_tags AS utm_tags_20, e0_.plain_text AS plain_text_21, e0_.custom_html AS custom_html_22, e0_.email_type AS email_type_23, e0_.publish_up AS publish_up_24, e0_.publish_down AS publish_down_25, e0_.read_count AS read_count_26, e0_.sent_count AS sent_count_27, e0_.revision AS revision_28, e0_.lang AS lang_29, e0_.variant_settings AS variant_settings_30, e0_.variant_start_date AS variant_start_date_31, e0_.dynamic_content AS dynamic_content_32, e0_.variant_sent_count AS variant_sent_count_33, e0_.variant_read_count AS variant_read_count_34, e0_.category_id AS category_id_35, e0_.translation_parent_id AS translation_parent_id_36, e0_.variant_parent_id AS variant_parent_id_37, e0_.unsubscribeform_id AS unsubscribeform_id_38, e0_.preference_center_id AS preference_center_id_39 FROM emails e0_ LEFT JOIN categories c1_ ON e0_.category_id = c1_.id WHERE e0_.variant_parent_id IS NULL AND e0_.translation_parent_id IS NULL ORDER BY e0_.subject DESC LIMIT 50 OFFSET 0’: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘e0_.preference_center_id’ in ‘field list’ - in file /xxxxxxxx/xxxxxxxxx/xxxxxxxxx/dmpages.com/m/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php - at line 71 [] []



I have made a copy of my previous mautic install directory

I then did a fresh mautic 2.11.0 install into original directory

I copied the config from old to new and still have this issue.



From my little understanding it looks more like a database select query/issue that’s not working.



any suggestions on how to fix?



Thanks

Hi there,

I just upgraded to new version v2.11.0 and now I get this error when trying to select email channel and I cant create or go any further with emails.

Error message is “The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.
System administrators, check server logs for errors.”

Here’s a copy of the log error that I think relates.

[2017-12-01 11:16:01] mautic.ERROR: DoctrineDBALExceptionInvalidFieldNameException: An exception occurred while executing ‘SELECT e0_.is_published AS is_published_0, e0_.date_added AS date_added_1, e0_.created_by AS created_by_2, e0_.created_by_user AS created_by_user_3, e0_.date_modified AS date_modified_4, e0_.modified_by AS modified_by_5, e0_.modified_by_user AS modified_by_user_6, e0_.checked_out AS checked_out_7, e0_.checked_out_by AS checked_out_by_8, e0_.checked_out_by_user AS checked_out_by_user_9, e0_.id AS id_10, e0_.name AS name_11, e0_.description AS description_12, e0_.subject AS subject_13, e0_.from_address AS from_address_14, e0_.from_name AS from_name_15, e0_.reply_to_address AS reply_to_address_16, e0_.bcc_address AS bcc_address_17, e0_.template AS template_18, e0_.content AS content_19, e0_.utm_tags AS utm_tags_20, e0_.plain_text AS plain_text_21, e0_.custom_html AS custom_html_22, e0_.email_type AS email_type_23, e0_.publish_up AS publish_up_24, e0_.publish_down AS publish_down_25, e0_.read_count AS read_count_26, e0_.sent_count AS sent_count_27, e0_.revision AS revision_28, e0_.lang AS lang_29, e0_.variant_settings AS variant_settings_30, e0_.variant_start_date AS variant_start_date_31, e0_.dynamic_content AS dynamic_content_32, e0_.variant_sent_count AS variant_sent_count_33, e0_.variant_read_count AS variant_read_count_34, e0_.category_id AS category_id_35, e0_.translation_parent_id AS translation_parent_id_36, e0_.variant_parent_id AS variant_parent_id_37, e0_.unsubscribeform_id AS unsubscribeform_id_38, e0_.preference_center_id AS preference_center_id_39 FROM emails e0_ LEFT JOIN categories c1_ ON e0_.category_id = c1_.id WHERE e0_.variant_parent_id IS NULL AND e0_.translation_parent_id IS NULL ORDER BY e0_.subject DESC LIMIT 50 OFFSET 0’: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘e0_.preference_center_id’ in ‘field list’ - in file /xxxxxxxx/xxxxxxxxx/xxxxxxxxx/dmpages.com/m/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php - at line 71 [] []

I have made a copy of my previous mautic install directory
I then did a fresh mautic 2.11.0 install into original directory
I copied the config from old to new and still have this issue.

From my little understanding it looks more like a database select query/issue that’s not working.

any suggestions on how to fix?

Thanks

@raymondkent how you trying to update mautic ?

Hi @bizcrony I have the same problem.

I tried to update mautic with the automatic install from inside the software.
The installation got stuck on the clear cache so I have cleared the cache manually with the command php app/console cache:clear

Now every thing seems to work ok but when I go to channels>email I got the error “The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator. System administrators, check server logs for errors.” see the image below:

How can I solve this problem?

Andrea

@iSquirrel can you give me your FTP , check ma profile

yes, where can I send you the credentials?

@iSquirrel check my profile and catch me if hard to find then you can email me kishankumawat@live.com

@bizcrony I found the error.
I tried to update the database schema with the command

php app/console doctrine:schema:update --force

and now everything is working well.

Thank you