Where is the configuration that used to be on local.php?

Your software
My PHP version is : 8.0
My MySQL/MariaDB version is : MySQL 8.0

Updating/Installing Errors
I am Installing and then trying to configure by editing the generated local.php file.

Installer Type: Zip file from GitHub releases:

Your problem

After a fresh 4.4.5 install, I went to the local.php file to configure my Mautic.
I found there just over 35 lines, instead of the usually 400+ or even 700+ lines in some other installs.

Is this a bug on 4.4.5 and the file being generated on my 4.4.5 is bad? Please let me know so I can open a bug report on Github.

or is it the new way of doing things?
If this is the new way… where are now all the configuration settings that were previously found in local.php?

Steps I have tried to fix the problem :slight_smile:
Reinstalled Mautic 4.4.5 three times to see if I got a different local.php file generated, to no avail…

Can you try this:

This worked for me using 4.4.6.

Have you opened Mautic and saved your configuration?

1 Like

Thank you @tobsowo and @rcheesley,

Going into the UI/configuration/settings and hitting the save button did the trick indeed.

My local.php is now a healthy 700+ lines, as expected.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.