Mautic Community Forums

2.7.0 User Permissions and Actions

Once again manually updated using ssh with mautic to 2.7.0 no problems of anykind clean update no errors of any kind. Still have the same problem as i have with version 2.6.0, 2.6.1 dealing with users and permissions with users mainly when trying to create a form and going to the actions area to pick anything listed doesn’t work receiving an error. The log shows this as it has with the past versions.



mautic.ERROR: SymfonyComponentDebugExceptionFatalThrowableError: Call to a member function getId() on null - in file /home/www/cms.i4campaigns.com/app/bundles/EmailBundle/Entity/EmailRepository.php - at line 353 [] []



This was before on line 331 now it shows it as line 353 so no fixes of any kind to get this working properly. I’m going to attach same link to video showing this problem and it seems nobody has any idea what is wrong because it’s in the emailbundle area. The admin side has no issues of any kind dealing with the forms and then picking the actions section to do anything it’s only when you have a user setup with roles they are able to do anything execpt dealing with the forms / actions area that are all connected to the emailrepository.php file 1 error that repeates itself. Other than that Mautic works wonderful, whats the point if you have users who can’t access and do anything that Mautic is meant to be using email to me a core peace to mautic is the emailbundle area itself.



I have 2 videos dated on march 3rd https://www.youtube.com/watch?v=tvjLDA-RAwE and another dated on Feb. 27th showing the process and how the error continues to show up. https://www.youtube.com/watch?v=bz1XpAWjc40 another related piece that deals with users is the language area, i have someone who speaks multiple languages German and English and rather be using German, i have to change it back to English before doing any updates because nobody with mautic goes in to do any language changes when an update happens you get a giant error with detection of languages and that the language picked if it’s not English it brings up an error creating a mess breaks the update, so from past experiences i have to change back to default langue on their account so the update is smooth and error free. All of this is connected when you setup roles and permissions for a user other than being an admin.

Once again manually updated using ssh with mautic to 2.7.0 no problems of anykind clean update no errors of any kind. Still have the same problem as i have with version 2.6.0, 2.6.1 dealing with users and permissions with users mainly when trying to create a form and going to the actions area to pick anything listed doesn’t work receiving an error. The log shows this as it has with the past versions.

mautic.ERROR: SymfonyComponentDebugExceptionFatalThrowableError: Call to a member function getId() on null - in file /home/www/cms.i4campaigns.com/app/bundles/EmailBundle/Entity/EmailRepository.php - at line 353 [] []

This was before on line 331 now it shows it as line 353 so no fixes of any kind to get this working properly. I’m going to attach same link to video showing this problem and it seems nobody has any idea what is wrong because it’s in the emailbundle area. The admin side has no issues of any kind dealing with the forms and then picking the actions section to do anything it’s only when you have a user setup with roles they are able to do anything execpt dealing with the forms / actions area that are all connected to the emailrepository.php file 1 error that repeates itself. Other than that Mautic works wonderful, whats the point if you have users who can’t access and do anything that Mautic is meant to be using email to me a core peace to mautic is the emailbundle area itself.

I have 2 videos dated on march 3rd https://www.youtube.com/watch?v=tvjLDA-RAwE and another dated on Feb. 27th showing the process and how the error continues to show up. https://www.youtube.com/watch?v=bz1XpAWjc40 another related piece that deals with users is the language area, i have someone who speaks multiple languages German and English and rather be using German, i have to change it back to English before doing any updates because nobody with mautic goes in to do any language changes when an update happens you get a giant error with detection of languages and that the language picked if it’s not English it brings up an error creating a mess breaks the update, so from past experiences i have to change back to default langue on their account so the update is smooth and error free. All of this is connected when you setup roles and permissions for a user other than being an admin.