Amazon SES: Delivery feedback not processed in Mautic - deactivating in SES

Your software
My Mautic version is: 4.4.1
My PHP version is: 7.4.29
My Database type and version is: 10.3.34-MariaDB-0ubuntu0.20.04.1

Your problem
My problem is:
I see some errors in the log and I suppose what is causing this… In Mautic I do not feel (yet) no side effect, but I suppose are the only 200 contacts that I have at the moment.
When more contacts are, I suppose the errors will have an impact on the performance of my mautic instance.

These errors are showing in the log:
many like these:
[2022-11-12 16:20:04] mautic.NOTICE: PHP Notice - Undefined index: Type - in file /var/www/html/m/app/bundles/EmailBundle/Swiftmailer/Amazon/AmazonCallback.php - at line 147 {"payload":{"notificationType":"Delivery","mail":{"timestamp":"2022-11-12T16:20:03.885Z","source":"\"=?UTF-8?B?SW9udcWjIE9qaWPEgw==?=\" ","sourceArn":"arn:aws:ses:eu-central-1:945827138349:identity/here_is_my_email_address","sourceIp":"88.numbers.124","callerIdentity":"MauticAPI2SES","sendingAccountId":"94numbers49","messageId":"010701846ca416ad-bf67f64a-db8b-4b58-94d3-2ed8843434b8-000000","destination":["email_address_of_contact"]},"delivery":{"timestamp":"2022-11-12T16:20:04.442Z","processingTimeMillis":557,"recipients":["email_address_of_contact"],"smtpResponse":"250 2.0.0 OK 1668270004 f19-20020a05600c44d300b45686534bbsi3113261wmo.131 - gsmtp","remoteMtaIp":"","reportingMTA":""}},"type":"Delivery"} {"hostname":"ubuntu-2gb-nbg1-1","pid":1577853}

[2022-11-12 16:20:04] mautic.WARNING: Received SES webhook of type '' but couldn't understand payload [] {"hostname":"ubuntu-2gb-nbg1-1","pid":1577853}

Steps I have tried to fix the problem:
As I remember that in Amazon SES I chosen one setting that was looking not quite right to me, I went again there and change it:

  • the errors comes with 1 activated (see picture)
  • changed to 2 - I suppose this is the right setting, as I do not need a delivery feedback - as understood from the error logs, Mautic cannot process this sort this answer.

Please a quick confirmation that my change (to 2) is the right setting.
Thank you and regards from Germany