Mautic Community Forums

An error occured while downloading the update package for Mautic 2.16

Your software
My Mautic version is: 2.15.3
My PHP version is: 7.2.27

Your problem
My problem is:
I can’t update Mautic 2.15.3 to 2.16

These errors are showing in the log:
[2020-02-13 17:01:50] mautic.ERROR: An error occurred while attempting to fetch the package: OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 104

Steps I have tried to fix the problem:
I first tried to Update through the dashboard, which didn’t work and resulted in the above mentioned error in the log. Then I installed Putty for Windows in order to update it through SSH CLI. There I always
got the following error “An error occured while downloading the update package.”

As I don’t have a php.ini inside the root directory of my Mautic installation, I tried to increase everything to the MAX inside the cPanel PHP Options settings, as you can see in the following Screenshot:

The error “An error occured while downloading the update package.” remained the same!

  1. What am I doing wrong?
  2. Is there a php.ini template with optimal setting for Mautic on Shared Hosting Environment?

@samo
I’m not sure whether your problem is related to your PHP settings, because you’re getting an OpenSSL error.

Could you try the following:

  • curl -L https://github.com/mautic/mautic/releases/download/2.16.0/2.16.0-update.zip > 2.16.0-update.zip --> this command attempts to download the update package. If you’re getting the same error here, something is wrong with your local installation (e.g. your system libraries like OpenSSL are out of date). If this does work though, the problem might indeed be in your PHP installation/configuration, we can then dive deeper into that.
  • openssl version --> this gives you the version of openssl installed. Could you post that here?
1 Like

@dennisameling Thank you for your suggestions and your help!

  • The attempt to download it from GitHub didn’t result in the exact same error, but a similar one to the log when I first tried to update within the Dashboard. Actually I’m not sure if it’s really an error, but after a failed attempt it returns: “curl: (56) SSL read: errno -5961”

  • The Open SSL version command returns: OpenSSL 1.0.1e-fips 11 Feb 2013

You have to update OpenSSL first:

The latest stable version is the 1.1.1 series.
This is also our Long Term Support (LTS) version, supported until 11th September 2023.
All other versions (including 1.1.0, 1.0.2, 1.0.0 and 0.9.8) are now out of support and should not be used.
Users of these older versions are encourage to upgrade to 1.1.1 as soon as possible.
Extended support for 1.0.2 to gain access to security fixes for that version is available.

Source: https://www.openssl.org/source/

1 Like

@aerendir Thank you for your suggestions and your help!

Unfortunately I can’t update OpenSSL myself. So I asked the Hosting Company they should update it. However they said, they wouldn’t update it, I quote:

We would like to let you know that the update of components like OpenSSL depend on cPanel. Also, cPanel itself ensures that all the latest security patches are available for all systems.
At the same time, the version of the package may not correspond to some security check-list and may not be the last available by the version number.
Thus, we would like to assure you that there are no security-related issues regardless of the version specified in phpinfo output.

I’m not sure if there is no other way around that?

Actually there might be an alternative and especially for Non-Techies a much simpler one! :blush:

Yesterday I wrote Softaculous Support and asked them to push the updated Mautic version, so that every Softaculous+Mautic user is able to easly update Mautic within Softaculous. Today they confirmed that their Script Team is now testing everything & shall release it on monday. I hope they will & it’ll work!

1 Like