Upgrade from 4.1.2 hangs on "Moving Package Contents" > In Progress

Your software
My PHP version is :
PHP Version 7.4.3

My MySQL/MariaDB version is (delete as applicable): MySQL/MariaDB
version mysqlnd 7.4.3

Updating/Installing Errors
I am : Updating
*Upgradingvia : Web

These errors are showing in the Mautic log :

These errors are showing in the upgrade_log.txt file (located in the root of your Mautic instance when an upgrade has been attempted - ensure you remove or redact any sensitive data such as domain names in the file path) :

[2022-10-24 16:09:50] mautic.ERROR: An error occurred while attempting to fetch the package: cURL error 18: transfer closed with 16766118 bytes remaining to read (see libcurl - Error Codes) for https://objects.githubusercontent.com/github-production-release-asset-2e65be/

Your problem
My problem is :
I’ve a couple of installation having the same issue. One is on a virtual machine at home, one is hosted on a shared hosting.
Both installations have the same problem.

Steps I have tried to fix the problem :
I’ve searched online for a solution but nothing really useful was found.

Thank you!

Hi there,

Firstly please ensure that you have curl enabled on your servers and that they can fetch the packages manually.

Also, please update at the command line and not in the user interface.

I didn’t mention that I’ve successfully update all my installations from 3.3.3 to 4.1.2 than I begun experience update trouble and all my installation are stuck at 4.1.2.
I’ve waited a little because I thougt the problem could be resolved on newer version but it is not.
The odd thing is that all installations even if hosted in different ways seems to have the same problem (actually they are 4 of them).

On my virtual machine I’ve the chance to update from command line (but couldn’t find walktrough instructions) while the hosted ones I guess I can’t…

Step by step instructions can be found here: Updating at command line | Mautic

It seems strange that you are having difficulties all of a sudden with Mautic - when you updated from 3-4 initially was everything working, eg it is only the 4.1.2 release you are having a problem with, or have you gone from 3 to 4.1.2 and now are having problems? Are you sure that Curl is working correctly and that the PHP version that is being used by Mautic is correct (from the system info page in Mautic)?

Hopefully other server admin gurus will chime in soon and give you some pointers!

sorry, found manual update process.
I’ve tried on my installation and got error:

while loading update information
permission denied on mautic/app/bundles/CoreBundle/Helper/UpdateHelper.php on line 196

while downloading update package
permission denied on mautic/app/bundles/CoreBundle/Helper/UpdateHelper.php on line 110

which permission are to be set to get the update process working? and how could it be possible to be working before?!

thanks in advance!

I’ve always updated via web interface every time since 3.3.3 until lately when I couldn’t update from 4.1.2 to the next one. Then I decided to wait and see if was some error…
PHP Version 7.4.3 from system info
and also from system info all writeble folder seems to be ok…