Mautic Community Forums

Update to 1.4.0 failed, new installation doesn't work

Any help, can not get this update done:



Update Available

Current Version 1.1.3

Upgrade Version 1.4.0



First it stuck every time on “Downloading Package - In Progress”. I try to let it run even 2 hours, nothing happened.



OK, I downloaded new 1.4.0 version, uploaded it via FTP to mautic sub-folder, extracted it, all OK, but when trying to access mydomain/mautic/installer, I got this:



The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

System administrators, check server logs for errors.



OK, I get via FTP /mautic/app/logs folder, and took down mautic_prod-2016-05-13.php error file where it says this … few times as I tried same installation few times



[2016-05-13 14:36:49] mautic.ERROR: Fatal: syntax error, unexpected ’ []



‘line 37’ in SmsApiController.php -file it has this:



return new Response(“You have been unsubscribed.”, 200, );



Can’t find any help from web for that, so I just tried ones more the old Mautic installation update and now, “Downloading Package Success” !! But now it stuck again here “Extracting Package - In Progress”.



Anyone any idea what I should do? Is there some way to update manually only files that have been changed?



This is what I have there:



Apache Version 2.2.29

PHP Version 5.4.38

MySQL Version 5.5.42-cll

Architecture x86_64

Operating System linux

Any help, can not get this update done:

Update Available
Current Version 1.1.3
Upgrade Version 1.4.0

First it stuck every time on “Downloading Package - In Progress”. I try to let it run even 2 hours, nothing happened.

OK, I downloaded new 1.4.0 version, uploaded it via FTP to mautic sub-folder, extracted it, all OK, but when trying to access mydomain/mautic/installer, I got this:

The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.
System administrators, check server logs for errors.

OK, I get via FTP /mautic/app/logs folder, and took down mautic_prod-2016-05-13.php error file where it says this … few times as I tried same installation few times

[2016-05-13 14:36:49] mautic.ERROR: Fatal: syntax error, unexpected ‘[’ - in file /mydomain/public_html/mautic/app/bundles/SmsBundle/Controller/Api/SmsApiController.php - at line 37 [] []

‘line 37’ in SmsApiController.php -file it has this:

return new Response(“You have been unsubscribed.”, 200, [‘Content-Type’ => ‘text/xml; charset=utf-8’]);

Can’t find any help from web for that, so I just tried ones more the old Mautic installation update and now, “Downloading Package Success” !! But now it stuck again here “Extracting Package - In Progress”.

Anyone any idea what I should do? Is there some way to update manually only files that have been changed?

This is what I have there:

Apache Version 2.2.29
PHP Version 5.4.38
MySQL Version 5.5.42-cll
Architecture x86_64
Operating System linux

12 mins now and still “Extracting Package - In Progress”

I went back to Dashboard, and start the update again … wow, now it got “Extracting Package - Success”!! … but next stuck here “Moving Package Contents - In Progress” … unbelievable !

And yes, I delete cache in the very beginning…

Well see, it’s still in “Moving Package Contents - In Progress”, so I will do it again going to Dashboard and try ones again the whole update… will let you know soon…

whups, can’t go anywhere but package moving continues :slight_smile: