Application stopped working after attempt to install plugin

Your software
My Mautic version is: 4.4.10
My PHP version is: 8.0.3
My Database type and version is: 10.5.16-MariaDB

Your problem
My problem is:
web application is not loading anymore, i get either “to many redirects” or 404
depend on the URL path

it all started after i tried to install SMS plugin

i did the following steps:

  1. unzipped the plugin file
  2. Clear the cache either by using mautic:cache:clear + cd /var/www/mautic/var/cache and rm -rf *
  3. Run the following command from your root directory of Mautic: php bin/console mautic:assets:generate

after the following steps the the web application stopped working …
i removed the plugin nothing help

i get either 404 or to many redirects (behind cloudflare)

please help … :frowning:

These errors are showing in the log:
no errors
Steps I have tried to fix the problem:
remove the plugin
remove cloudflare proxy
play with htaccess and apache conf
no success …


Firstly you can just delete the plugin from the plugin directories and delete the cache - everything will be working again.

Secondly regarding the app - did you generate assets and delete cache?

Yes I tried all that
Didn’t work

What actually it do ? Build assets?
Could it change the httpd conf ?

no it will not change the http conf.

I know it has only been tested up to 4.4.6 and only now I see you are on 4.4.10.

PM me with the url of your site, will have a look.

Can you see what is happening on your web server logs ?