BUG: URGENT! - Campaigns > Multiple inputs to nodes no longer works

Your software
My Mautic version is: 4.0.1
My PHP version is: 7.4
My Database type and version is: 10.2.40-MariaDB-1:10.2.40+maria~bionic-log

Your problem
Campaign builder UI will not allow multiple feeds into nodes. I have a move to campaign step that is fed from two paths in the program. If I remove a feed I can no longer add that path back.

If one of those feeds is moved or changed it will not allow me to re-connect it. Nor can I create new nodes and add two or more feeds to them. The previous feed link disappears.


These errors are shown in the log:
Today’s Mautic error log is empty. Check server error log for error messages Mautic didn’t have a chance to catch.

No corresponding errors in Apache error log

No errors shown in chrome dev console

Steps I have tried to fix the problem: Don’t know of any other than clearing PROD cache. Also cleared browser cache.

All of these campaigns were created in v3 series and existed prior to upgrading to v4.

I tested creating a new program in v4 with a simple flow and the same behaviour is seen. I cannot feed a node from two paths on the campaign builder.

@joeyk - Tagging you just so you see it. Sorry for the interruption.

I didn’t know that this option is even available. :slight_smile:
You can use ‘jump to action’ to merge two branches.

So I’m assuming that this was a v4 design change?

If it was, honestly IMO, this was a mistake. It takes way longer to create the event, name it and then choose the event to go to. The previous way of dragging a link and dropping it was much simpler. It’s also how it works in Eloqua.

This new approach may seem cleaner visually in a way but to me, the old way made more sense visually of what the actual flow was.

Any input @rcheesley ?

Which version did you upgrade from? I had the impression joining paths is not working since M3

I upgraded from a v3 stream, I don’t recall the exact subversion but I always kept up to date.

My camps were created some time ago when I first installed Mautic. I’m not a massive user so I don’t have a ton of stuff built out nor have I made many changes to how things were set up. They just worked so there was no need.

Now when I’m starting to do a little more with it is when I’m finding these things.

I’m a little surprised that this was considered as something that needed changing.

I just tested on 2.16. You already couldn’t unify branches like that there. I really wonder how you did it :slight_smile:

The very first version I installed was in the v3 stream. I never used v2 at all.

I have my own install and I installed it for a client as well. Both installs were a v3 stream and the camp builder allowed me to join nodes that way.

Could this have been added in an early v3 release and then removed in v4?

@rcheesley knows all :wink: lol