Mautic Community Forums

Campaign emails not sending

Hello,

I have these error logs, and also campaign emails aren’t sending and not tracking clicks and email opens




[

Code:
2016-10-31 13:53:50] mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentDebugExceptionFatalThrowableError: "Call to a member function isRendered() on null" at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php line 215 {"exception":"[object] (Symfony\Component\Debug\Exception\FatalThrowableError(code: 0): Call to a member function isRendered() on null at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php:215)"} [] [2016-10-31 13:56:20] mautic.NOTICE: PHP Notice: Undefined index: title - in file /var/www/vhosts/post.domain.eu/httpdocs/mautic/vendor/symfony/form/FormView.php - at line 108 [] [] [2016-10-31 13:56:20] mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentDebugExceptionFatalThrowableError: "Call to a member function isRendered() on null" at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php line 215 {"exception":"[object] (Symfony\Component\Debug\Exception\FatalThrowableError(code: 0): Call to a member function isRendered() on null at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php:215)"} [] [2016-10-31 13:56:25] mautic.NOTICE: PHP Notice: Undefined index: title - in file /var/www/vhosts/post.domain.eu/httpdocs/mautic/vendor/symfony/form/FormView.php - at line 108 [] [] [2016-10-31 13:56:25] mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentDebugExceptionFatalThrowableError: "Call to a member function isRendered() on null" at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php line 215 {"exception":"[object] (Symfony\Component\Debug\Exception\FatalThrowableError(code: 0): Call to a member function isRendered() on null at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php:215)"} [] [2016-10-31 12:50:18] mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentDebugExceptionFatalThrowableError: "Call to a member function getId() on null" at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/EmailBundle/Helper/PointEventHelper.php line 29 {"exception":"[object] (Symfony\Component\Debug\Exception\FatalThrowableError(code: 0): Call to a member function getId() on null at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/EmailBundle/Helper/PointEventHelper.php:29)"} [] [2016-10-31 13:00:11] mautic.ERROR: [MAIL ERROR] Expected response code 250 but got code "550", with message "550 5.7.60 SMTP; Client does not have permissions to send as this sender " Log data: ++ Starting Swift_Transport_EsmtpTransport <> EHLO post.domain.eu <> STARTTLS <> EHLO post.domain.eu <> AUTH LOGIN <> c3J2cmVwb3J0c0BzeW5lcmdpdW0uZXU= <> JTg5UDFtS2sxcFQ3 <> MAIL FROM: <> RCPT TO: <> DATA <> . << 550 5.7.60 SMTP; Client does not have permissions to send as this sender !! Expected response code 250 but got code "550", with message "550 5.7.60 SMTP; Client does not have permissions to send as this sender " (code: 550) [] [] [2016-10-31 13:30:11] mautic.ERROR: [MAIL ERROR] Expected response code 250 but got code "550", with message "550 5.7.60 SMTP; Client does not have permissions to send as this sender " Log data: ++ Starting Swift_Transport_EsmtpTransport <> EHLO post.domain.eu <> STARTTLS <> EHLO post.domain.eu <> AUTH LOGIN <> c3J2cmVwb3J0c0BzeW5lcmdpdW0uZXU= <> JTg5UDFtS2sxcFQ3 <> MAIL FROM: <> RCPT TO: <> DATA <> . << 550 5.7.60 SMTP; Client does not have permissions to send as this sender !! Expected response code 250 but got code "550", with message "550 5.7.60 SMTP; Client does not have permissions to send as this sender " (code: 550) [] [] [2016-10-31 16:02:02] mautic.NOTICE: PHP Notice: Undefined index: type - in file /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/CampaignBundle/Controller/EventController.php - at line 241 [] [] [2016-10-31 16:02:02] mautic.ERROR: Notice: Undefined index: eventType - in file /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/CampaignBundle/Controller/EventController.php - at line 242 [] []

Hello,
I have these error logs, and also campaign emails aren’t sending and not tracking clicks and email opens

[2016-10-31 13:53:50] mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentDebugExceptionFatalThrowableError: "Call to a member function isRendered() on null" at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php line 215 {"exception":"[object] (Symfony\Component\Debug\Exception\FatalThrowableError(code: 0): Call to a member function isRendered() on null at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php:215)"} [] [2016-10-31 13:56:20] mautic.NOTICE: PHP Notice: Undefined index: title - in file /var/www/vhosts/post.domain.eu/httpdocs/mautic/vendor/symfony/form/FormView.php - at line 108 [] [] [2016-10-31 13:56:20] mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentDebugExceptionFatalThrowableError: "Call to a member function isRendered() on null" at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php line 215 {"exception":"[object] (Symfony\Component\Debug\Exception\FatalThrowableError(code: 0): Call to a member function isRendered() on null at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php:215)"} [] [2016-10-31 13:56:25] mautic.NOTICE: PHP Notice: Undefined index: title - in file /var/www/vhosts/post.domain.eu/httpdocs/mautic/vendor/symfony/form/FormView.php - at line 108 [] [] [2016-10-31 13:56:25] mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentDebugExceptionFatalThrowableError: "Call to a member function isRendered() on null" at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php line 215 {"exception":"[object] (Symfony\Component\Debug\Exception\FatalThrowableError(code: 0): Call to a member function isRendered() on null at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/LeadBundle/Views/Lead/form.html.php:215)"} [] [2016-10-31 12:50:18] mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentDebugExceptionFatalThrowableError: "Call to a member function getId() on null" at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/EmailBundle/Helper/PointEventHelper.php line 29 {"exception":"[object] (Symfony\Component\Debug\Exception\FatalThrowableError(code: 0): Call to a member function getId() on null at /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/EmailBundle/Helper/PointEventHelper.php:29)"} [] [2016-10-31 13:00:11] mautic.ERROR: [MAIL ERROR] Expected response code 250 but got code "550", with message "550 5.7.60 SMTP; Client does not have permissions to send as this sender " Log data: ++ Starting Swift_Transport_EsmtpTransport << 220 AM2PR03CA0030.outlook.office365.com Microsoft ESMTP MAIL Service ready at Mon, 31 Oct 2016 13:00:03 +0000 >> EHLO post.domain.eu << 250-AM2PR03CA0030.outlook.office365.com Hello [00.00.00.000] 250-SIZE 157286400 250-PIPELINING 250-DSN 250-ENHANCEDSTATUSCODES 250-STARTTLS 250-8BITMIME 250-BINARYMIME 250 CHUNKING >> STARTTLS << 220 2.0.0 SMTP server ready >> EHLO post.domain.eu << 250-AM2PR03CA0030.outlook.office365.com Hello [00.00.00.000] 250-SIZE 157286400 250-PIPELINING 250-DSN 250-ENHANCEDSTATUSCODES 250-AUTH LOGIN 250-8BITMIME 250-BINARYMIME 250 CHUNKING >> AUTH LOGIN << 334 VXNlcm5hbWU6 >> c3J2cmVwb3J0c0BzeW5lcmdpdW0uZXU= << 334 UGFzc3dvcmQ6 >> JTg5UDFtS2sxcFQ3 << 235 2.7.0 Authentication successful target host HE1PR0301MB2057.eurprd03.prod.outlook.com ++ Swift_Transport_EsmtpTransport started >> MAIL FROM: << 250 2.1.0 Sender OK >> RCPT TO: << 250 2.1.5 Recipient OK >> DATA << 354 Start mail input; end with . >> . << 550 5.7.60 SMTP; Client does not have permissions to send as this sender !! Expected response code 250 but got code "550", with message "550 5.7.60 SMTP; Client does not have permissions to send as this sender " (code: 550) [] [] [2016-10-31 13:30:11] mautic.ERROR: [MAIL ERROR] Expected response code 250 but got code "550", with message "550 5.7.60 SMTP; Client does not have permissions to send as this sender " Log data: ++ Starting Swift_Transport_EsmtpTransport << 220 AM4PR0701CA0007.outlook.office365.com Microsoft ESMTP MAIL Service ready at Mon, 31 Oct 2016 13:30:03 +0000 >> EHLO post.domain.eu << 250-AM4PR0701CA0007.outlook.office365.com Hello [00.00.00.000] 250-SIZE 157286400 250-PIPELINING 250-DSN 250-ENHANCEDSTATUSCODES 250-STARTTLS 250-8BITMIME 250-BINARYMIME 250 CHUNKING >> STARTTLS << 220 2.0.0 SMTP server ready >> EHLO post.domain.eu << 250-AM4PR0701CA0007.outlook.office365.com Hello [00.00.00.000] 250-SIZE 157286400 250-PIPELINING 250-DSN 250-ENHANCEDSTATUSCODES 250-AUTH LOGIN 250-8BITMIME 250-BINARYMIME 250 CHUNKING >> AUTH LOGIN << 334 VXNlcm5hbWU6 >> c3J2cmVwb3J0c0BzeW5lcmdpdW0uZXU= << 334 UGFzc3dvcmQ6 >> JTg5UDFtS2sxcFQ3 << 235 2.7.0 Authentication successful target host DB5PR0301MB2053.eurprd03.prod.outlook.com ++ Swift_Transport_EsmtpTransport started >> MAIL FROM: << 250 2.1.0 Sender OK >> RCPT TO: << 250 2.1.5 Recipient OK >> DATA << 354 Start mail input; end with . >> . << 550 5.7.60 SMTP; Client does not have permissions to send as this sender !! Expected response code 250 but got code "550", with message "550 5.7.60 SMTP; Client does not have permissions to send as this sender " (code: 550) [] [] [2016-10-31 16:02:02] mautic.NOTICE: PHP Notice: Undefined index: type - in file /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/CampaignBundle/Controller/EventController.php - at line 241 [] [] [2016-10-31 16:02:02] mautic.ERROR: Notice: Undefined index: eventType - in file /var/www/vhosts/post.domain.eu/httpdocs/mautic/app/bundles/CampaignBundle/Controller/EventController.php - at line 242 [] []

The email issue I answered in your other thread.

These logs are very strange; the timestamps are all out of order.

It looks like something’s gone wrong with your your Mautic installation. If you’ve just done an upgrade look here: https://www.mautic.org/community/index.php/conversation/post/16500