Mautic Community Forums

Campaign stuck- "Pending Actions" not getting processed

Your software
My Mautic version is: 3.3.2.
My PHP version is: 7.3.27
My Database type and version is: “Olson” Timezone Database Version 0.system

Your problem
My problem is: I am very new to mautic- I am using SES as my delivery server, My campaigns is are not fully sent, I have pending actions in the campaigns which are not getting completed.

I have installed mautic on cpanel- softaculous

Below are crons I have-

3,8,13,18,23,28,33,38,43,48,53,58 mautic:messages:send >/dev/null 2>&1
3,8,13,18,23,28,33,38,43,48,53,58 mautic:broadcasts:send >/dev/null 2>&1
2,7,12,17,22,27,32,37,42,47,52,57-mautic:segments:update >/dev/null 2>&1
3,8,13,18,23,28,33,38,43,48,53,58 mautic:campaigns:update >/dev/null 2>&1
3,8,13,18,23,28,33,38,43,48,53,58 mautic:campaigns:trigger >/dev/null 2>&1
2,7,12,17,22,27,32,37,42,47,52,57 mautic:emails:send >/dev/null 2>&1
2,7,12,17,22,27,32,37,42,47,52,57 mautic:email:fetch >/dev/null 2>&1

Steps I have tried to fix the problem: I have tried tweeking the queue settings, Below is the screenshots- Kindly help me fix this
image

Hello,
Is this your real path in the cronjobs?
You need to add the php command and path, like:

3,8,13,18,23,28,33,38,43,48,53,58 php /pathtoyourmautic/mautic:messages:send >/dev/null 2>&1

Also PMd you with more help

Joe, Thanks for replying
I have the PHP path to mautic
/usr/local/bin/php /home/roservices/public_html/
They look good. I triggred about 658 email from a campaign- Few are pending actions in campaign. But Sending SES shows the emails were delivered

Delivered: Mautic shows it?
What is in your /mautic/var/spool folder? any files?

Mautic doesnt show that, and the spook is empty.

Had some scheduled emails today from the campaign, but all failed. Below is screenshot.

You need to check the spool hete:
/mautic/var/spool

Otherwise you don’t know if the emails are sent or just spooled.
If you have queue sending set, then spooling = sending for mautic stats

/mautic/var/spool is empty

So emails were out okay?
You also said, that Emails were delivered according to SES?

No, the send set of emails didnt go out. . SES doesnt show if it was sent.

Check the logs and post here please.
I think you are trying to send from an unverified address or the port is blocked or you are in sandbox.
Joey