Cannot Create Email Channel

Your software
My Mautic version is: 4.15.0
My PHP version is: 7.4.16
My Database type and version is: ?

Your problem
My problem is: I cannot create an email channel using the “new” button in the top right corner of the “channels” —> “emails” section. The button doesn’t respond.

These errors are showing in the log: None

Steps I have tried to fix the problem: Deleted cache folder in WINSCP, but it did not help.

I have the same problem. I can’t create new email templates.

Also editing already created email templates doesn’t react.
The thin blue progress bar runs from left to right, but the page remains the same.

No entry in the log files.

Any suggestions?

Kind regards

You need to check if you have writing rights in your temp folder.
Just run a full chown in your mautic folders.


Many thanks for you answer Joey!

That did solve my problem. My question now is, can it be that during an update the ownership has been changed somehow? Other possibility I can’t think of.

Kind regards


Hey, what usually happens is, that you login as root, and you clear the cache as root. This way some folders will be not writable.
Happy it worked! Keep automating!


Helo Joey,

today started working again with Mautic and experienced the same behaviour. After resetting the rights as you suggested, everything works as expected.

For me this means, that during the night some process is setting the rights wrong. Of what is your idea?

Kind regards


I think you are using ssh as sudo and execute commands NOT as www-data user (which is probably your apache user) It is okay, just make sure you finish your commands with restoring the proper ownership.

I’m using ISPConfig for domain and site configuration and hosting. Thus Mautic has the ownership of web1.client7 e.g.
When I’m working on the server as root, I understand your point. The strange thing is, that I haven’t changed anything and today somehow the ownership changed. I’ll check this tomorrow. Could it be that some cron jobs modify the ownership?

Can be yes. Who is running the cron? :slight_smile:


I just started using Mautic. I love it but I’m frustrated right now. The setup has been overwhelming but I’m trying my best as I’m not techy.

I have issues with creating an email channel. It’s the same issue. Save &.Close and Apply buttons usually grey out. I’ve been battling with it for hours.

Hello Seun, is it shared hosting you use?
Did you install via bitnami or ssh?

Hello Joey,

the cron is run by root. It should be run by the user, correct?

Well, if the cron runs it, it might execute thigs in such a way, that it ruins your permissions.

It must be something else, that ruins my permissions, because the Mautic cron jobs are running twice per hour. But I experience the problems after the night.

I too struggled with the same issue with the channel->emails not working. Looking at chrome dev console I noticed the 403 so I contacted my hosting support. At the end of this all I was able to only get a few templates to work but when I asked about the rules being triggered in mod_security it is related to potential xss injection flag. The relevant trigger is below:

Matched phrase "<!--" at ARGS:emailform[customHtml].

Running a chown in my root user on putty did not fix the problem for me.

  1. sudo chown -R www-data:www-data /var/www/html/mautic/
  2. sudo chmod -R 755 /var/www/html/mautic/