Cannot create new blank emails or emails from templates

Your software
My Mautic version is 4.4.4
My PHP version is: 8.0.25
My Database type and version are: MySQL version 5.7.27

Your problem
My problem is:

Couldn’t see the save/edit buttons on the New Email popup.

When I try to create a new email from the “Send Email” popup. There is no option to save or edit the blank or pre-made templates.


Following is the screencast for the same

These errors are showing in the log:
No errors are showing in the log

Steps I have tried to fix the problem:
I used 1-click Web Apps Installer through my hosting panel to install Mautic’s latest version.

I also tried downloading and installing Mautic’s latest stable version from Github, but the same issue occurred.

It would be of great help if someone could figure it out for me. Following is the error log section which has no errors whatsoever.

Hi, it looks like the install is either broken or limited on purpose.
The problem with one click install is that they give you the illusion of a perfect install and no real way to troubleshoot.
If you are using this Mautic on a shared host, I suggest to change to a VPS asap, before you invest more time.

Hi, thanks for the reply.
Yeah, I am using Mautic on shared hosting but all my other websites and installations are working fine on it. Currently, I cannot move to VPS for a reason. I also tried fresh installation through Github stable file but issue turned out to be the same.

Is there any way to troubleshoot it?

Check browser console to see if there are any errors in it

This is what is seen in the console

Seems that a variable is not being declared before the javascript is loaded.

Any idea, how can I fix this?

There are not one sure way to fix this since there are varieties of different issues which can cause this error from memory problem to improperly web server configuration.

I am leaning more toward to web server itself because if it was the Mautic code then you would not be the lone ranger experiencing this issue. Like what @joeyk said, something on web server is limiting it or preventing a variable being declared.

Could be permission or missing libraries etc.

Curious … what version is php on the server at?

I have updated the server’s PHP version to 8.1. But still the issue is there.

Mautic 4.4.3 is not compatible with 8.1. I would stick with 7.4

1 Like

Mine is v. 4.4.4. In fact it was behaving the same on previous PHP versions.

go to mauitc root and try to run:

rm -r var/cache/prod/*
php bin/console mautic:assets:generate

1 Like

I am a noob in running these kinds of commands. Any easier way to solve it?

The brutal truth is, that it’s almost impossible to run a Mautic instance without touching the server via command line from time to time.
Either you get this skill and take the risk of failure, or you hire someone to do it for you.
I know it sounds ‘not user friendly’, but we are not there yet.

Mautic is 4.4.4
PHP is: 7.4.30
Data Base: 10.3.31-MariaDB
In Subdomain

Same mistake.
It cannot, and does not save, any type of new email.

I deactivated and reactivated the GrapesJS Plugin.
Improved Mautic performance with commands
rm -r var/cache/prod/*
/usr/bin/php bin/console mautic:assets:generate

  • But the ERROR continues!

Are you using emojies in your email?

Nope, as I mentioned in the question, I cannot see the save email bar on the create email modal, let alone create the email.

Did anyone here investigate the mautic logs on the server side? Is there any hint about the issue there?

Logs are usually stored in: <mautic-root>/var/logs

I would try to replace vendor folder with the one from mautic release, for example for mautic version 4.4.4, I would use vendor folder from: < >.