Mautic Community Forums

I can't save the emails

My software v3.3.2
My PHP version is* : 7.3.27
My MySQL/ 10.3.28-MariaDB-log-cll-lve

These errors are showing :
Apr-2021 04:43:27 UTC] PHP Notice: Trying to access array offset on value of type null in /home/publsuys/public_html/mautic/app/bundles/EmailBundle/Views/FormTheme/Email/_emailform_dynamicContent_entry_filters_entry_filters_entry_widget.html.php on line 14

In the log it shows this error:
[2021-04-11 05:40:46] mautic.NOTICE: PHP Notice - date_default_timezone_set(): Timezone ID ‘’ is invalid - in file /home/publsuys/public_html/mautic/app/bundles/CoreBundle/EventListener/EnvironmentSubscriber.php - at line 58 {“event”:"[object] (Symfony\Component\HttpKernel\Event\GetResponseEvent: {})",“request”:"[object] (Symfony\Component\HttpFoundation\Request: GET /mautic/ HTTP/1.1\r\nAccept: text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.9\r\nAccept-Encoding: gzip, deflate, br\r\nAccept-Language: es-ES,es;q=0.9\r\nContent-Length: 0\r\nCookie: _fbp=fb.1.1616511320540.222973867; 8d7bc800820a87384bdd9d4c354da66f=317e873e87f0daff0ff92ff2cf47597e\r\nHost: publick2.com\r\nPurpose: prefetch\r\nSec-Ch-Ua: “Google Chrome”;v=“89”, “Chromium”;v=“89”, “;Not A Brand”;v=“99”\r\nSec-Ch-Ua-Mobile: ?0\r\nSec-Fetch-Dest: document\r\nSec-Fetch-Mode: navigate\r\nSec-Fetch-Site: none\r\nSec-Fetch-User: ?1\r\nUpgrade-Insecure-Requests: 1\r\nUser-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.114 Safari/537.36\r\nX-Forwarded-For: 186.26.117.10\r\nX-Forwarded-Proto: https\r\nX-Https: on\r\nX-Php-Ob-Level: 1\r\nCookie: _fbp=fb.1.1616511320540.222973867; 8d7bc800820a87384bdd9d4c354da66f=317e873e87f0daff0ff92ff2cf47597e\r\n\r\n)"}

My problem, I can’t save the mail, I try to use the different templates but it’s the same, it doesn’t save

Steps I have tried to fix the problem :
change the php version
I cleared cache

Same problem !

I think this has nothing to do with shared hosting. You should include in the requirements for Mautic installation that it is not compatible with shared hosting. There are no clear solutions for this issue or at least there is no interest in answering or giving a clear solution for people who are not experts in coding and programming.
I am very sorry but it is reality.

I’m using Mautic on shared hosting. It is working great.
I think it should not be included.

There are millions of different environments.
If someone knows how to install Mautic, they should be able to understand the limitations of their shared hosting.

1 Like

If you can’t save emails it is usually:

Other software on the same server blocks Mautic in a very evil way.
Somehow the folder permissions got messed up. Just make sure you reset them right.
You are trying to save a html, that has some evil things in them, that generates an error.

Joey

I had the same problem and solved it finally by having the firewall authorizing the inputs coming from my ip.
Have a good automation day !