Could not extract the contents of the ZIP archive [SOLVED]

Your software
My PHP version is : 8.0.22
My MySQL/MariaDB version is: 8.0.28-0ubuntu0.20.04.3

Updating/Installing Errors
I am : Updating
Upgrading/installing via : Command Line

These errors are showing in the installer :

The Mautic update could not complete successfully because of the following error: Could not extract the contents of the ZIP archive to the filesystem. PHP Warning: ZipArchive::extractTo(/home/username/ failed to open stream: Permission denied in /home/username/ on line 82

These errors are showing in the Mautic log :

mautic.WARNING: Command mautic:update:apply exited with status code 1 {“hostname”:“servername”,“pid”:381758}

Your problem
My problem is : Can’t update, stuck on v4.4.6. I have successfully updated the past several updates using CLI, but this one isn’t working. I am using a separate directory for Mautic, <> and thought I had tweaked the .htaccess file to accommodate that, but has something changed?

Steps I have tried to fix the problem : Contacted my webhost to see if there were permission errors. They found one, but removing it had no effect. Still cannot update.

UPDATE: While I was writing this post, I cleared the cache and that did it (along with removing the bad permission). Just posting this in case someone else has the problem.