Create new segment filter 4.2-rc front end issue on filter

Your software
My Mautic version is: 4.2-rc
My PHP version is: 7.4
My Database type and version is: tidb

Your problem
My problem is:

(see screenshot)

After upgrading to try 4.2 rc, when i create a new segment, the filter screen is blank.
Selecting a pre-existing segment (e.g. one that was created prior, that has filters) works and shows options.

ANy suggestions on where i might look to debug?

These errors are showing in the log:

there were no errors logged either in javascript web console nor php/nginx log.

Steps I have tried to fix the problem:


So this problem remains in 4.2.0 (released).

I don’t see an error in the php logs.
i don’t see an error in the javascript console.

I just don’t see the rest of the field fill in to edit. if i open an existing segment, it works and can be edited, but no new terms added.

Any pointers on how to debug?

yes have tried:

  • clear cache (browser, server)
  • firefox, chrome
1 Like

is discussing the issue on github.

Same problem with a new install on AWS. No existing segments, so I don’t know if those would have worked, but exact same issue. Tried same steps, and also browsers plus Edge.

ok i fixed it for me.
i ran mautic:assets:generate followed by assets:install

The media dir was dirty from previous (4.1) release.

How did you execute it? with php?

console mautic:assets:generate
console assets:install
1 Like

Thanks … That what fixes it for me …

The update to 4.2.1 fixed it for me!

Same issue - update to 4.2.1 fixed it for me along with a server cache clear.


I have tried to run
console mautic:assets:generate
console assets:install
i got this result
bitnami@ip-*****:/opt/bitnami/mautic/bin$ sudo /opt/bitnami/php/bin/php /opt/bitnami/mautic/bin/console mautic:assets:generate
Production assets have been regenerated.
bitnami@ip****:/opt/bitnami/mautic/bin$ sudo /opt/bitnami/php/bin/php /opt/bitnami/mautic/bin/console assets:install

Installing assets as hard copies.

[OK] No assets were provided by any bundle.

any step should i need to follow ?
Thanks in advance