Mautic Community Forums

Critical Error - Urgent Help Needed Please

Hi All. We have just had an instance go down, tried clearing the cache, tried chowning the directory and still getting erorr.
When I run cache:clear --env-prod I get the following:
PHP Parse error: syntax error, unexpected ‘=>’ (T_DOUBLE_ARROW), expecting ‘)’ in /var/www/mautic/app/bundles/NotificationBundle/EventListener/CampaignSubscriber.php on line 142

This is one of the errors from the logs:
2021/10/12 16:37:20 [error] 1231#1231: *430 FastCGI sent in stderr: “PHP message: Symfony\Component\Debug\Exception\FatalThrowableError: Parse error: syntax error, unexpected ‘=>’ (T_DOUBLE_ARROW), expecting ‘)’ - in file /var/www/mautic/app/bundles/NotificationBundle/EventListener/CampaignSubscriber.php - at line 142” while reading response header from upstream, client: 80.246.137.51, server: amautic, request: “GET /mtc.js HTTP/1.1", upstream: “fastcgi://unix:/run/php/php7.4-fpm.sock:“, host: “maiutic”, referrer: “https://www.domain.co.il/r/מסעדת%20רוקפור%20דימונה”

Hey @mikew is this a new or existing install?

existing install 3.3.x. Very big instance, a few integrations. It just started giving these errors all of a sudden.
Luckily I had a backup of the files from yesterday so what I did was unpack them in a different directory, updated my nginx to point to this directory and everything is working.

However I do not know what caused this or how to fix it…