Mautic Community Forums

CSRF token is invalid

Hello,



I’m unable to install mautic latest release on my vps.

I always get “The CSRF token is invalid. Please try to resubmit the form.”

I already set the session_path in php.ini but the error remain.

This is my php.ini http://paste.xcentrik.online/dinaxiwixakohuvo.vhdl.



system: Debian 8

web server: Apache 2.4.20

php 5.6.20


I have the same on cloud Mautic, emailed support, asked 5 times for help on Slack and haven’t be able to use cloud Mautic for 2 or 3 weeks…

yes, the directory is writable by the webserver. i’v already restarted apache and php-fpm

Hello,

I’m unable to install mautic latest release on my vps.
I always get “The CSRF token is invalid. Please try to resubmit the form.”
I already set the session_path in php.ini but the error remain.
This is my php.ini http://paste.xcentrik.online/dinaxiwixakohuvo.vhdl.

system: Debian 8
web server: Apache 2.4.20
php 5.6.20

I’m having the same problem now. It goes in an out with that error or Mautic cloud. Any solution?

I had this error trying to upload a CSV of contacts for import (using the reference mautic.net implementation as a paying customer, with our own subdomain). Managed to get around it by switching browsers (and trial and error). Now getting same error again consistently (in both browsers) when trying to upload a new customised theme in /s/themes (for our subdomain of mautic.net). Any ideas what could be going wrong.

@lightweight @Plarcher I’ve temporarily fixed the problem by clearing all cookies for my Mautic domain. It works for a day or so then I have to clear the cookies again.

Interesting, thanks, @brianmhays. That sounds like a bug… :slight_smile:

I similarly found it works after clearing domain cookies… but then fails again shortly after a successful form submission.

We had the same problem when using Safari, but switching to Chrome or Firefox when accessing Mautic resolved the problem.