Custom Objects: Segment Filter "is not"

Your software
My Mautic version is: 4.3.1
My PHP version is: ?
My Database type and version is: MySQL

The problem
I have created a new custom object called “cars” with Acquia’s custom objects plugin (installed from their staging-branch in github - not with composer). Inside this object I have a single select field called “Brand”. Now I want to filter a segment that has all contacts who do not have a car with the brand “Fiat”.


But when I update the segment, it contains all contacts (including the ones who do have a Fiat).
When I use the filter “brand = Fiat”, then it works and only shows the contacts who indeed do have a Fiat.

I really like the plugin and would like to use it a lot - but having this fixed is quite critical for our use cases… Thanks for any help! :slight_smile:

These errors are showing in the log: none

Steps I have tried to fix the problem:

  • None so far, I don’t know how I should go about fixing it.

Seems to have been solved - I must’ve been still in Beta when I tested it …