Mautic Community Forums

date.timezone setting on Debian 7 64bit

I tried to install this wonderful software but I can’t. I change my date.timezone in my php.ini and nothing. I don’t have much experience in Symphony



Thanks



I tried to install this wonderful software but I can’t. I change my date.timezone in my php.ini and nothing. I don’t have much experience in Symphony

Thanks

Hi

If you set date timezone in php.ini it should be reflected - but you may need to restart your webserver to see it change. Also make sure you’re updating the right php.ini.

On command line you can run:

php --ini

Which will give you a list of all the php.ini files you’re using:

for example:

php --ini

Configuration File (php.ini) Path: /etc/php5/cli
Loaded Configuration File: /etc/php5/cli/php.ini
Scan for additional .ini files in: /etc/php5/cli/conf.d
Additional .ini files parsed: /etc/php5/cli/conf.d/05-opcache.ini,
/etc/php5/cli/conf.d/10-pdo.ini,
/etc/php5/cli/conf.d/20-curl.ini,
/etc/php5/cli/conf.d/20-gd.ini,
/etc/php5/cli/conf.d/20-intl.ini,
/etc/php5/cli/conf.d/20-json.ini,
/etc/php5/cli/conf.d/20-mysql.ini,
/etc/php5/cli/conf.d/20-mysqli.ini,
/etc/php5/cli/conf.d/20-newrelic.ini,
/etc/php5/cli/conf.d/20-pdo_mysql.ini,
/etc/php5/cli/conf.d/20-readline.ini

That’s mine. That said, this is referencing the /cli/ directory, mautic runs on web so instead of the /cli you’re actually going to need to find the web .ini file.

For me if I dig through that I find:

/etc/php5/apache2/php.ini

That’s where I set the timezone setting:

[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = “America/New_York”

There’s tons of resources on how to set this. For example:
http://www.inmotionhosting.com/support/website/php/setting-the-timezone-for-php-in-the-phpini-file

If you can’t figure it out, I highly suggest asking your host to set this for you.