Disable Email Required for CSV Import! I use Mautic for more than just emails!

Your software
My Mautic version is: 3.3.3
My PHP version is: 7.3.29
My Database type and version is: MariaDB

Your problem

The problem I am having is that I am using Mautic for non-email related campaigns. I am being forced to enter fake emails in my CSV files to import my data. I wish I did not have to do this.

Request #1: It would be great if we could have a feature that does not require email on import or if someone could share the code with me to do it manually.

Request #2: We need to update the Import documentation because this was very confusing (I already made a request on Git Hub). It does not mention that email is required. Furthermore, I was confused because if a contact is previously manually created but one uses a unique field, it will match to that contact on CSV import and disable the “email required” rule. This is why I did not notice this rule existed at first… I am sure a lot of people are confused on this logic.

It may seem weird to some that I am using Mautic for non-email related purposes but it is a powerhouse of a program for Excel related tasks with campaigns and spinning data with a GUI interface.


or use concatenate function in excel to add dummy emails
or insert none@none.com and use—>

Hello @EJL thank you for your response. I actually did notice the “required” field with email but with my testing, this did not fix my issue. Even with email required turned off, when I import my data sets, it will not import unless there is an email. The only way it would import data on an import without an email is if there was another “unique” field such as username that was matched to an existing field that I created manually. I think this might be a bug? I also tried on an existing mautic instance that I have been running for over a year and installed a fresh instance to double check and still having the same issues. Have you been able to import fields without email when you disable this? I wonder if there is a piece of code or a setting I have to change… I am pretty sure it is a bug though.

Also yes, the “hack” to fix this is to use the concatenate feature in excel and spin up fake emails but this is problematic with our sales funnel as we sync information between different systems…

Just an update @EJL I now got this to work. It is very strange though, it would not work when there are zero contacts in Mautic, but when I added a couple manually with emails, all of a sudden I could import contacts without emails…

1 Like

Excellent news. I’m glad it worked for you @mybpoconsultant

I found out what went wrong here and why my contacts were not showing when I imported without email. There is a small toggle in Mautic that is very easy to miss and it is set on by default. It is called “Toggle anonymous contacts” – If you do an import and you do not see your data, you need to select this and then your contacts will show… Very easy one to miss…