Mautic Community Forums

email/unsubscribe translation

Hello,



I was trying to translate ‘unsubscribe landing page’ (Starts with ‘We are sorry to see you go!’)

  1. under app/bundles/EmailBundle/Translations I created pl_PL folder and copied messages.ini (from en_US) to this new folder
  2. then I edited file as this



    ; mautic.email.unsubscribe.text=“Unsubscribe to no longer receive emails from us.”

    mautic.email.unsubscribed.success=“Przykro nam że rezygnujesz! %email% nie będzie otrzymywał od nas więcej wiadomości e-mail. Jeśli chcesz zmienić zdanie i nadal otrzymywać wiadomości kliknij tutaj.”

    ; mautic.email.urlvariant=“Public Preview URL”


  3. Then I set new ‘list e-mail’ with unsubscribe link, set polish translation (pl_PL) and send it to selected lead list
  4. But after clicking the unubscribe link in e-mail message - message in landing page is still in english



    I’m missing something?



    Regards

Hello,

I was trying to translate ‘unsubscribe landing page’ (Starts with ‘We are sorry to see you go!’)

  1. under app/bundles/EmailBundle/Translations I created pl_PL folder and copied messages.ini (from en_US) to this new folder
  2. then I edited file as this

    ; mautic.email.unsubscribe.text=“Unsubscribe to no longer receive emails from us.”
    mautic.email.unsubscribed.success=“Przykro nam że rezygnujesz! %email% nie będzie otrzymywał od nas więcej wiadomości e-mail. Jeśli chcesz zmienić zdanie i nadal otrzymywać wiadomości kliknij tutaj.”
    ; mautic.email.urlvariant=“Public Preview URL”
  3. Then I set new ‘list e-mail’ with unsubscribe link, set polish translation (pl_PL) and send it to selected lead list
  4. But after clicking the unubscribe link in e-mail message - message in landing page is still in english

I’m missing something?

Regards

Language translations for other than en_US language are located in translations directory (not in each bundle). Mautic will download your language when you select it in Mautic configuration. You can modify the translation at Transifex:

https://www.transifex.com/mautic/mautic/

A script builds translations from Transifex once a day. If you want to update already downloaded language from Transifex, delete it from translations directory, save Mautic configuration again and cleare cache.

I know this it pretty old, but where exactly can I configure Mautic so that it downloads necessray languages automatically?[quote] Mautic will download your language when you select it in Mautic configuration.[/quote]

OK, I think I got it. The language files will be downloaded after I change the language settings in the configuration. As I have users with seven different languages (at the moment) in my database, I have to change my own settings 7 times to get all necessary languages. That is not very practicable.Obviously most of the Mautic users here have only english speaking users in their database, otherwise this should be a topic that has to be tackled with some higher priority.

Hello, I have an issue that seems to be related to this one.
I also try to translate the (‘We are sorry to see you go!’) message. I used transifex to translate the message.
I am Dutch so I installed the Dutch language in the Mautic backend.
I see that there is a directory mautic/translation/nl
I removed the NL directory and saved my settings in Mautic to recreate it.

When I look into the recreated directory I can see that within the mautic/translations/nl/EmailBundle directory there is no messages.ini file.
I believe that the translation of the 'We are sorry to see you go!") normally needs to be in the messages.ini file.
I tried to add a messages.ini file myself and adapt the message inside this file in the mautic/translations/nl/EmailBundle directory but this does not seems to help.
I also tried to create a override directory in the root map of the translations and put a messages.ini file there but also without results.

So the issue that I have is that the message is not changing, also not after deleting the cache directory and reapply the language. Anybody any idea?