Mautic Community Forums

Emails are TOTALLY blocked

Hello,
I have a free Mautic installation installed on my own hosted server.

Everything was working fine for weeks, at least almost everything, including sending emails, both template and segment ones. I was using also complex campaigns to track user actions and automate answers.

Then I had the bad idea to switch the email sending mechanism from “Send immediately” to “Queued” in the Email Configuration section.

Then everything stopped to work: no more emails are sent, neither if I use the queued mode CRONJOBS (mautic:emails:send, mautic:broadcasts:send), nor if I try to send immediately.

I tried almost everything:

  • cleaned the app/spool directory
  • cleaned the app/cache directory
  • cloned and created new segment emails from scratch
  • toggled between Queued and Immediate mode several times
  • called many CLI commands (incuding mautic:emails:send, mautic:broadcasts:send, cache:clear)
  • modified the app/config/local.php as in a backup copy I made

Any help?

Thanks in advance
Max

BTW I’m using the latest version of MAUTIC

Hello, please I need HELP since I am totally BLOCKED.

No email could be sent.

@Massimo B. is your all contact are went to DO NOT CONTACT ?

No, no. I have 1500 contacts and everything worked fine.

I reinstalled Mautic in ANOTHER directoty, and it’s always the same problem: when I send an email to a segment, it says:

“Queue, Email #1, for sending?”

instead of sending them immediately as usual. And they are somehow queued but never departing. And of course I call the method:

Executing console mautic:emails:send
Mautic is not set to queue email.

and it’s not configured for queuing. If I configure it, nothing changes and nothing departs:

Executing console mautic:emails:send

without results.

I repeat: even installing on a new directory, different database, same problem. And never had before.

Try mautic:email:process

It is not existing that command, apparently.

Funny enough, the Send Example email is working.

I’ becoming CRAZY.

I installed in a NEW server, NEW empty database. Configured to send emails IMMEDIATELY since the beginning.

And always queuing and not sending.

I suspect there is something wrong in my hosting? But then why example emails are sent?

Have you check your cron jobs??
Test email works because are not been trigger by any cronjob

Found the problem, it is the PHP version.

It happened after 12.2.1 update and I didn’t think about it.

Basically:

Mautic 12.10.1 and PHP 7.0 are ok and emails are flowing.

Mautic 12.2.1 is not compatible with PHP 7.0 nor 7.1 and emails are blocked.

Mautic 12.2.2 is not compatible with my MySQL DB (too big column).

And with my ISP I could just have PHP up to 7.1.

What I don’t understand is why the compatibility with PHP isn’t checked during installation

i have Php 7 running Mautic 2.12.2

I couldn’t install 12.2.2 due to a bigger (767) than allowed column.

How to fix this?

And there is more: it is NOT the PHP version.

In the fresh new installation, the one working, I copied the contacts (about 1000) and a new mail, and I sent it.

Result? Like it happened before, after few hundred emails (249), they stopped to flow.

I don’t really know what to think… maybe I am blocked by my ISP due to to many emails?