Mautic Community Forums

FB Field Mapping

Hi Alan,



I can’t seem to match up the FB fields and the Mautic fields as in the profile it will only say en_US for my leads that should have had that information captured. Any ideas?



Kind regards,

Damon

Hi Alan,

I can’t seem to match up the FB fields and the Mautic fields as in the profile it will only say en_US for my leads that should have had that information captured. Any ideas?

Kind regards,
Damon

Hi Damon,

When you say that you can’t match up the FB and Mautic fields, are you saying that you can’t match them up in the Facebook integration config due to an error or that you have them matched up, but leads are not getting updated with the data?

If getting an error, we need to figure out what that error is by looking app/logs/mautic_prod.php to see if anything is recorded there.

If not getting an error and leads data is just not updated, in the Features tab of the Facebook integration, do you have the option to match up lead field data checked? Do you have a custom lead field with an alias of “facebook” and the leads have their Facebook username populated in it?

Unfortunately, Facebook does not allow us to search for users by email and using by name can generate literally hundreds of matches. So we had to limit the search to just their Facebook handle.

Thanks!
Alan

Hi Alan,

According to all that you’ve pointed out I do believe all is setup correctly and I have experience setting up Facebook apps as well. I have created an account for you to login if you have the time to take a look.

automate.moign.com
User: alan
Pass: password123

Kind regards,
Damon