Mautic Community Forums

Facebook contact mapping

Hello,



I tried to configure the Facebook plugin. I have authorize the app in Facebook. And I have enable the app in Facebook.

I use the facebook loginnames in the Facebook field on the contacts. In the plugin I have configured the field for contact-mapping.



But I I try to update the contact. No data is updated by Facebook.



Is this plugin working?



Any tips?



Kind regards,

Ronald

Hello,

I tried to configure the Facebook plugin. I have authorize the app in Facebook. And I have enable the app in Facebook.
I use the facebook loginnames in the Facebook field on the contacts. In the plugin I have configured the field for contact-mapping.

But I I try to update the contact. No data is updated by Facebook.

Is this plugin working?

Any tips?

Kind regards,
Ronald

Hi MxyzptlkFishStix,

Thanks. Good to know.

I was hoping there was also some contact mapping. This because if you configure the facebook plugin there is the possibility to setup contact mapping. So… all these fields aren’t working… if I understand correctly

Hi MxyzptlkFishStix,

I tried to add the Social Login to my mautic form. The login buttons are visible on the form. When I try to test it, and login with my own social media account, to login process will go without any errors.

But the fields (Firstname, Lastname, Email) on my form are not filled in by facebook or twitter.

Do I have to configure any field mapping for my form?

Thanks

I think this tutorial from our friend @chris0928 might be useful:

Https://innotiom.com/mautic-facebook-plugin-setup/

Https://innotiom.com/mautic-twitter-integration/

Hi Carlos,

I have setup my facebook and twitter plugin exactly the same as in the tutorial from @chris0928. I can also confirm that the plugins are working. I can login with the Social login buttons.

But, when I login with a facebook account, the form fields like Firstname, Lastname and Email are still empty after a social login. The user still have to fill these fields manually.

Also after a social login. There is a new contact created in Mautic, the facebook data is not merge to the existing contacts in Mautic. This contact has the same email address as the Facebook login.

Any tips???

Thanks

.

Hi MxyzptlkFishStix,

[quote]You can map fields. The permissions under public_profile require no review from FB./quote]

What is the best way to map these fields in Mautic? Should I configure these fields in the Facebook Plugin? Or somewhere else in Mautic?

Thank you.

Hi,

In my case the same situation - login by FB and Twitter work but no data in mapped fields Please any help.

Hi @MxyzptlkFishStix -could you help us. My plugin have been integrated correctly, I confirm access by FB and it is the end. Mautic doesn’t see any new contact…

I have found the Bug and created an Issue on Github: https://github.com/mautic/mautic/issues/4042

This is the Patch that I propose: https://github.com/mautic/mautic/pull/4043

[quote]What is the best way to map these fields in Mautic? Should I configure these fields in the Facebook Plugin? Or somewhere else in Mautic?
[/quote]

Hi ronald_d!
It seems like you did not get any answer yet. I was trying to find out how to map the values fetched with the facebook login API as well and discovered your post. As the solution wasn’t given here, I tried out myself and found it:

When you add a field to the mautic form you have to state the right “Field HTML name” under the tab “attributes”.

For the Email its simply “email”.
For everything that runs under public_profile you have to enter "public_profile{userobject}… so for example for the full name used on Facebook: “public_profile:name”.

See here for a list of possible user objects.: public_profile Reference

That way the field in the mautic form will be filled with the data of the userobject, when the user clicks the facebook login button. Woohoo, great.

Hi there. I completed all of the steps of this tutorial to integrate FB to Mautic however when I try to authorize the app I keep getting this error message https://goo.gl/KiR199

As you can see on my Mautic settings https://goo.gl/peD7Yy I am using the correct website URL, have the right app credentials, and have the app published. You can also see the matching app domain on my FB app here https://goo.gl/WTXXPa

Can someone tell me if I’m missing something or how to fix this? Thanks

Silly question, but did you try it from an anonymous browser window? Remember that if you’re logged in it’s not going to update correctly.

Hi @cynmob, sorry I missed your reply as you did not tag me on it. Yes I did try with the anonymous browser, however the issue persists, don’t know why it would change. Don’t really know what you refer to when you say “Remember that if you’re logged in it’s not going to update correctly.”

Hey @xtremewebsites, same problem here!!! Have you found a solution? -.-’

Ok, solution found! :slight_smile:
https://www.nextscripts.com/instructions/facebook-social-networks-auto-poster-setup-installation/october-2017-facebook-changes/