Mautic Community Forums

/form/generate.js?id=1 returning blank

Upon creating a new form for embedding on a website, using the Automatic method, I’m having an issue of the JS actually rendering any output.



I suspect it is a permissions issue but have no managed to debug it yet as error logs aren’t showing anything related to it.



Has anyone else had the same or similar issue with /form/generate.js?id=1 not displaying any output?

Upon creating a new form for embedding on a website, using the Automatic method, I’m having an issue of the JS actually rendering any output.

I suspect it is a permissions issue but have no managed to debug it yet as error logs aren’t showing anything related to it.

Has anyone else had the same or similar issue with /form/generate.js?id=1 not displaying any output?

Hi!

A few things to check. First, is the form published? Second, is 1 the actual id of the form you want? If not, make sure that matches. Third, are you getting any javascript errors on the page it’s embedded into?

Thanks!
Alan

Issue was related to the publishing time of the form.

Application is picking up server time and not locally set time zone hence publishing is in the past and I was still in the future.

Thanks Alan

Set your default timezone in the Configuration and times should then be local to you. You may have to go back and adjust other items if you set publish up dates. All date/times are saved to the database as UTC but displayed to you according to what you have set in the Configuration and/or user’s account (which defaults to UTC).

Thanks!
Alan

I figured that was the case but it isn’t what actually is happening in this case.

The issue is happening on our self hosted but I haven’t verified the issue on localhost yet so I’ll submit if I can replicate it again.

Peter

Obviously let us know if you find a discrepancy!

Did you by chance verify the timezone of your user via the drop down in the upper right -> Account. There is an option there to use the System Default Timezone but when I looked at the code, it looks like new users are defaulting to UTC rather than that. I’m going to get that changed as it should definitely default to whatever the system default timezone is.

Thanks!
Alan