Mautic Community Forums

GoDaddy Email setup with Office365

After months and months of tech support and these forums i finally got this to work, hope it helps others that have been posting about it as well.



The issue was this: I have Godaddy hosting with Office365 mail offered by GD (So i can max out my outgoing mail to 10k per day)



Every time i put in the 365 settings it would give me a connection error #111 refused from server message. Most felt it was a blocked port 587 and happened with port 25 as well.



Long story short, here are the settings you will need to have:



Service to send mail through: Other SMTP Server

SMTP host: relay-hosting.secureserver.net

SMTP port: 25

SMTP encryption type: None

SMTP authentication mode: None



••••••••••••••••••••••••••••••••

The next great hurdle was cron jobs. Most of the jobs to put in were totally wrong as far as routing and structure, It seems that GD had some quirks that I finally found that stopped giving me errors. So here is what I found that finally worked:



/usr/local/bin/php -q /home/{username}/public_html/{websitefolder}/app/console mautic:segments:update



the -q is for quiet mode which will not send any notifications, however I left that out for testing and will probably not put it back so i can watch if something bad happens.



••••••••••••••••••••••••••••••••



Finally, when I tested my emails after the first fix in the Mautic settings/mail I received it. However when i did it under contacts/dropdown send email it did not.



After a numerous calls to tech support I finally found someone who changed my cpanel email to send through my main email address and Abracadabra it all of a sudden started working.



••••••••••••••••••••••••••••••••



Now I am finally up and going and am super happy and hope this little bit of suffering on my part is helpful to others.

After months and months of tech support and these forums i finally got this to work, hope it helps others that have been posting about it as well.

The issue was this: I have Godaddy hosting with Office365 mail offered by GD (So i can max out my outgoing mail to 10k per day)

Every time i put in the 365 settings it would give me a connection error #111 refused from server message. Most felt it was a blocked port 587 and happened with port 25 as well.

Long story short, here are the settings you will need to have:

Service to send mail through: Other SMTP Server
SMTP host: relay-hosting.secureserver.net
SMTP port: 25
SMTP encryption type: None
SMTP authentication mode: None

••••••••••••••••••••••••••••••••
The next great hurdle was cron jobs. Most of the jobs to put in were totally wrong as far as routing and structure, It seems that GD had some quirks that I finally found that stopped giving me errors. So here is what I found that finally worked:

/usr/local/bin/php -q /home/{username}/public_html/{websitefolder}/app/console mautic:segments:update

the -q is for quiet mode which will not send any notifications, however I left that out for testing and will probably not put it back so i can watch if something bad happens.

••••••••••••••••••••••••••••••••

Finally, when I tested my emails after the first fix in the Mautic settings/mail I received it. However when i did it under contacts/dropdown send email it did not.

After a numerous calls to tech support I finally found someone who changed my cpanel email to send through my main email address and Abracadabra it all of a sudden started working.

••••••••••••••••••••••••••••••••

Now I am finally up and going and am super happy and hope this little bit of suffering on my part is helpful to others.

Updated above…

cool

@lewisone i tried the settings you gave, and got this error (below)…can you help ?

Connection could not be established with host http://relay-hosting.secureserver.net/ [Unable to find the socket transport “http” - did you forget to enable it when you configured PHP? #70426344] Log data: ++ Starting Swift_SmtpTransport !! Connection could not be established with host http://relay-hosting.secureserver.net/ [Unable to find the socket transport “http” - did you forget to enable it when you configured PHP? #70426344] (code: 0)
++ Starting Swift_SmtpTransport !! Connection could not be established with host http://relay-hosting.secureserver.net/ [Unable to find the socket transport “http” - did you forget to enable it when you configured PHP? #70426344] (code: 0)

Sorry Augentia, it’s been months and didn’t see your response. I honestly don’t know but If I were to guess I would say that you need to update your PHP version?? If I remember correct when I was setting it up that is what this meant.

Also, make sure the email be handled is Queue for this.

Also, lol… Check to make sure that your cron jobs are set up. I seem to have found a bunch that I had to dig for to get this to work, here are mine, the routing was tricky and those dohicky numbers at teh end are incredibly important to get them to run:

/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:segments:update >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:campaigns:trigger >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:emails:send >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:campaigns:rebuild >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:social:monitoring >/dev/null 2>&1

/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:webhooks:process >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:iplookup:download >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:maintenance:cleanup --days-old=365 --dry-run >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:broadcasts:send [–id=ID] [–channel=CHANNEL] >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:campaigns:update >/dev/null 2>&1

/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:emails:send >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:leadlists:update >/dev/null 2>&1
/usr/local/bin/php /home/mygodaddyname/public_html/domain/app/console mautic:email:process >/dev/null 2>&1