Help with DB migration from 2.16.5 to 3.2.4

Your software
My Mautic version is: 2.16.5
My PHP version is: 7.3.27
My Database type and version is: MySQL 5.7
My environment is hosted environment in linux with Apache (OVH)

Your problem
I have tried to update my production 2.16.5 version using the button but never worked. So I have installed a totally new fresh version of 3.2.4 in a test environment that is working. But now I would like to have some advise about what I should do to download the database from 2.16.5 and upload it to the 3.2.4 environment. I guess that only backup and restore will not work.
Thank you in advance for support and help from community

Hi there,

I would suggest you pull your production Mautic instance into a development area, run the migration there, and then you will have an updated database.

There is no other supported way to update to Mautic 3 other than using the provided upgrade script.

When you say to use the provided script are you referring to upgrade_v3.php that is in the production environment or upgrade.php that comes with the I am asking as the upgrade_v3.php never worked as well as the button… it was always hanged (I guess loop).

The only way to update from 2->3 is via the upgrade script.

You should do the update at the command line if it is hanging in the UI.

Use the same commands that you would use with a regular update and it will step you through the update.

Thank you. I will try to do it in that way. Let’s see if finally I will be lucky :slight_smile:

No I was not lucky :frowning:
I executed mautic command:

Executing console mautic:update:find

Version 3.2.4 of Mautic is available for download. Please visit for more information. To update, you can run ‘php upgrade_v3.php’ from the command line.

Then tried apply

Executing console mautic:update:apply

Update aborted.

And then the php upgrade_v3.php hanged again.

You need to run that command at the command line.

Type what it says - php upgrade_v3.php - in your terminal and it will step you through one step at a time.

No need to open it in the browser!

Sorry to bother you with this matter. I have my instances hosted so I can not access to the terminal as you suggested