I get error when upgrading to 3 version

Your software
My PHP version is :7.3
My MySQL/MariaDB version is (delete as applicable): MySQL/MariaDB version 5. 6 on shared hosting

Updating/Installing Errors
I am (delete as applicable): Installing / Updating
Upgrading/installing via (delete as applicable) : Web / Command Line

These errors are showing in the installer :

  • Your MySQL/MariaDB version is not supported. You need at least MySQL 5.7.14 or MariaDB 10.2 in order to run Mautic 3.

These errors are showing in the Mautic log :

These errors are showing in the upgrade_log.txt file (located in the root of your Mautic instance when an upgrade has been attempted - ensure you remove or redact any sensitive data such as domain names in the file path) :

Your problem
My problem is :

Steps I have tried to fix the problem : called host, they said mysql is 5.6 on shared and they cant upgrade it…cause it is shared

Another option you have is to get a VPS or a dedicated server (recommended), or find another shared hosting that has an upgraded MySQL. There is nothing much you can do about it.

Can I just run it in 2.6 version for ever…and not upgrade?

What are the limitations of MySQL in version 5.5.65, that Mautic 3.0 can’t be installed/upgraded over it?

When a software recommends at least a specific version of another dependable program, it means it relies on a set or a couple of features that is only designed to work with that version or later.

It doesn’t mean it won’t work, but it just won’t function accordingly, and if a proper check is in place, it won’t even let you get pass.

Sometimes, it might be that the older version of the dependable program is vulnerable.