Mautic Community Forums

Image upload with CKEditor

Hi guys



All we get is spinning wheel while trying to add slides via the Page Builder: http://cl.ly/image/3E10371n252Q



And the same happens with using the image tool in CKEditor directly: http://cl.ly/image/2q0s2t3L342T

Hi guys

All we get is spinning wheel while trying to add slides via the Page Builder: http://cl.ly/image/3E10371n252Q

And the same happens with using the image tool in CKEditor directly: http://cl.ly/image/2q0s2t3L342T

Hi Steve,

That’s been fixed with https://github.com/mautic/mautic/pull/198. Sorry about that. It slipped through us before releasing 1.0 :-/

If you prefer not to patch before we get the next patch version released, the work around is a manual upload of the image through ftp into media/images and enter the url to the image in the image dialogue.

Thanks!
Alan

Thanks Alan

We’re still testing and familiarizing ourselves with Mautic. Happy to wait for the next release.

Hi guys,

I have the same problem as mentioned above.
I tried with 1.2.3 version and a git checkout from 21 Jan 2016. (1.2.4-dev).
I see nothing in the logs.
Any suggestions what i cab do to debug this problem ?

Thanks, helmut

It could be a filesystem permission issue

I applied the PR 1506, and it’s still not working, I read and tried other similar posts on the forum, no results.
If you have any ideas to try please let me know, desperate at this point… Self hosting on linux, nothing in mautic and httpd logs, filemanager just spins and nothing happens.

Yes, I cleared the cache (delete each time I try a different option), deleted browser history, I even tried one of the suggestions on this forum – refreshing the Assets folder. Running apache 2.4, php 5.4, mautic 1.3 .
Thanks,

When I inspect in the browser (where filemanager is trying to load), I see the following:
“Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience”
Any idea if this might be the cause?
I’m also not sure about the .htaccess files – starting from the top level, there’s another under /app and /app/bundles … is there a specific way these need to be placed, modified, etc…

Hi Guys,

Same issue here. All file permissions have been set. I’m using 1.3.1 version.
Looking forward for any kind of solution.

Tks,
Francis.

Works for me
https://github.com/mautic/mautic/pull/1506

Thank you @ alanhartless,
I have got the uploader working, earlier I missed the code section, just applied the patch and it got working.

Thanks @ djmaxjr for the confirmation and re-quoting the solution : https://github.com/mautic/mautic/pull/1506

+1 @nichung

Just installed it and having the same issue

Looking forward to the community advice, as it would be helpful if a patch exists or maybe a workaround in code instead of the FTP option.

Many Thanks,
Vik

Hey all,

I’ve been having the same issue, and the config reports that all necessary folders are writable. The logs don’t report anything either. Is anyone else experiencing this issue, and if so, are you also using ftp to get around it? Thanks!