Mautic Community Forums

Import contacts not processing

Your software
My Mautic version is: 2.15.2 - probably. I haven’t done the 15.3 update but can’t find this information in mautic??
My PHP version is: 7.1.33

Your problem
My problem is: Ok, Mautic newbie here so assume I know nothing and ELI5. thank you.

I’m trying to import my CSV of contacts with zero results. No errors, no attempts at importing, nothing. I have checked that my lists are ~ 1k contacts and all files are UTF8 downloaded via google sheets. I can’t get anything to import either via cron or directly in the browser.

I’m sure there’s something very basic I’m missing here. Help?

These errors are showing in the log: none

Steps I have tried to fix the problem: googled

What’s under Contacts - Import History?

Are there any logs from previous dates in /app/logs/?
Example: mautic_prod-YYYY-MM-DD.php

Imports list: the first four were my optimistic expectation that these would be fine and the cron would do it’s thing overnight. I let it sit there for 8 or 9 days (I have the cron set to trigger twice a day) before I turned them off and went digging for more info.

The top two are the downloaded-from-google versions, first the full list which I tried in-browser (nothing) and then the reduced list which I tried in browser (again nothing, just sat there) and left overnight. Cron didn’t pick it up.

/app/logs/? is a 404. Either I’m missing where that’s supposed to point or I don’t understand the address? My install is at tamiveldura.com/newsletter, so should that full address be tamiveldura.com/newsletter/app/logs/? (that’s the 404)

And your example file name is escaping me entirely. Where am I looking for that?

You have to access that directory, and the files inside, through your panel’s file manager. It’s not accessible via your browser. Also, what’s in your web server logs? There might be something in there as well around the time you tried your imports.

Go to /s/sysinfo and search for the variables of max_execution_time, post_max_size, upload_max_filesize and post them here.

/app/logs/? found!

10.28: https://pastebin.com/F1V4hzwL
11.3: https://pastebin.com/hKKM0p2H

under s/sysinfo
Max_Execution: server 30, master 30
Post_max: server 256m, master 256m
Upload_max: server 128m, master 128m

so… the files I’m offering are just too big?

I doubt that a csv with 1000 records is any larger than a few hundred Kb.

PHP is running out of memory. What’s memory_limit on the sysinfo page??

memory_limit: sys 128M, master 128M

I should note this is a fresh install without any alterations or plugins.

Bump it up to 256M, restart your web server or PHP daemon and try one of your imports.

How do I make that change?
Baby steps are appreciated.

Edit: scratch that I found it

Ok, Mautic confirms the local value is at 256M but the master still sits at 128M.

going to try an import.

edit: No dice. It just sits there, same as before. No indication anything is moving or that there’s a problem. I didn’t see a new log in apps/logs but if one is only generated when the cron tries to proc, that won’t happen for a few hours.

What OS are you running @tamiveldura?

windows 10
Chrome (latest)

@tamiveldura - you got cron set up (mautic:import) ?
Tried running cron in bash and see if that works?

@tamiveldura, no man, on your server!! :weary:

Remember that bit where I said I was a newbie? I’m sorry!

@kenm I’ve got the cron set to go twice a day

php /tamiveldura.com/newsletter/app/console mautic:import

I don’t know what running in bash means but I’ll google and report back

Edit: yeah I don’t know nearly enough about how this works to run anything on a command line without someone giving me exact commands. In fact, I’m not even sure I have access to a terminal for the server.

@Yosu_Cadilla I’m renting space on a shared server that I access through cpanel. If you know where I can find the info, I’m happy to report it to you.


I expected this to be a basic setup item I overlooked. If Mautic isn’t 90% plug and play, it’s not the solution I’m looking for. Getting into terminal commands is way over my head. If you guys have run through the obvious newbie errors, let me know and I’ll dig into other solutions.

@tamiveldura you can’t run Mautic without at least a basic understanding of Linux and the command line.
It’s not that hard, really.

I would start by installing Mautic manually (instead of using cpanel).

Here’s how to do it:

And here’s why you don’t want to use cpanel:

I don’t consider Linux difficult. I run an installation parallel to windows. It’s simply not where I want to spend my time. I’m the only one running my business and it’s a matter of 80% of the work making none of the money.

So like I said, if Mautic isn’t mostly a plug and play then it’s not the solution I’m looking for. I do appreciate all the work you guys have put in. I’ve learned quite a bit in the last week.

@Yosu_Cadilla

That’s not the problem that they’re having.

@tamiveldura

Follow the instructions below and increase the memory limit incrementally until you don’t have any memory exhaustion errors.

Increase PHP Memory Limit In cPanel

@tamiveldura Mautic is definitely not plug and play.