Install in subdirectory : problem after upgrading from 3.1.2 to 3.3.5

I was trying to upgrade with command line from 3.1.2 to 3.3.5

i’m using an 02switch hosting (mutualised) for my website.

My mautic is in a subdirectory and everything was fine since today :

Here is the folder organization:
Symlinc in /wordress/marketing → …/mautic
and i’m accessing mautic using web address with

Before upgrading, everything was fine, but right now I can’t find what’s wrong, i’m redirected to the wordpress router who finaly display a 404 (it’s logic that it can’t found anything)

i’ve properly changed those value in app/config/local.php
and all path for the storage

Can you help me please ?

PS: it’s only a “transition” cause i’ll next upgrade to mautic 4, but i tried upgrading directly to mautic 4 and i had the same issue

I also tried to disable mod_security but this doesn’t fix my problem

best regards

Please make sure you always read the release notes when upgrading.

This explains in the linked issue the actions you need to take if you’re using a sub folder.

1 Like