Installation Error on step 2 - Mautic 2.15.3

Your software
My Mautic version is: 2.15.3
My PHP version is: 7.1.33

Your problem
My problem is:

Running this from a sub-domain on a VPS hosted on Fasthosts.

Files have been uploaded and installation goes OK until I am asked to setup the admin user. I type my name and email address and try and continue. After 5 seconds I get a 500 error.

I have checked the timeout for scripts and it’s 30 seconds. I have also checked the logs. I have pasted the error I get from the logs below. Note that I have put hidingthisstuff to hide my domain etc for security.

These errors are showing in the log:

AH01071: Got error ‘PHP message: PHP Warning: require(/hidingthisstuff/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /hidingthisstuff/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209\nPHP message: PHP Warning: require(hidingthisstuff/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /hidingthisstuff/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209\nPHP message: PHP Fatal error: require(): Failed opening required ‘/hidingthisstuff/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:/opt/plesk/php/7.1/share/pear’) in /hidingthisstuff/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209\n’, referer: https:/

Steps I have tried to fix the problem:

I have looked through other posts related to similar issues people are having. I have deleted the cache as some suggest as well as using a different MySQL database and neither of these have worked. I have also extended the timeout for PHP scripts upto 120 seconds and that didn’t work. In addition I did increase the memory allocation to 500mb and also with no joy. My last step was to set all files and folders to 755 in via Filezilla - this also didn’t work.

Any advice or pointers would be useful.


There is something missing in step 1 , can you redo installtion and try …

Step 1 is the database setup. I have ran this a couple of times but still have the same issue. I have also created a new database to see if that was the issue but the exact same problem persists. All of the database tables are created by the script as I can see them. It is when I try and setup the admin user…that is where the error then occurs.

Make sure everything under Mautic root is owned by the web server user.

1 Like

As told by @MxyzptlkFishStix, this is typically a problem related to unix permissions.

Mautic uses Doctrine to interact with the database.

To make the execution faster, Doctrine uses a system that creates real PHP classes from the code: a sort of code compilation like in the traditional programming languages.

Those files need to be accessible by the Apache user: if they are owned by two different users, then Mautic is not able to read them.

The other reason is that, for some reasons, the proxy classes were not generated at all: check the path indicated in the error and see if there there are the php files: if they are not present, then you need to create them manually (

You’re right, they’re not there. I ran the command : ```
app/console cache:warmup --env=prod

However the response back was "No such file or directory".

I'm not a big user of SSH or Symfony so any additional help would be very much appreciated.

It looks as though it is the root user.

As the root user, use the following command:
chown -R webserveruser.webserveruser /location/of/mautic/

webserveruser = the user the web server process runs under. It could be apache, nginx or www-data.

Once that’s done, don’t run app/console cache:warmup. Just make sure /location/of/mautic/app/cache/prod/ is deleted and refresh the Mautic dashboard inside your browser. The act of doing that will refresh the cache.

Hello @nickmenai,

What OS are you running? Ubuntu, CentOS?

CentOS 7.The server is a VPS on Fasthosts servers.

were you able to fix this issue?