Mautic Community Forums

Installation error when trying to create dB

Hi:

I copied the Mautic files up to my hosting account via FTP, created a dB (MariaDB not MySQL but should work, ya?) and the /installer page loads as expected.

But after entering dB info. in Step 1, I’m getting an error with a bunch of dB info then “… General error: 1709 Index column size too large. The maximum column size is 767 bytes.”

Any ideas?

Thank you!

Hi @AmauticUse :

The MariaDB ver. 10.1 is using the InnoDB engine. After searching a bit, seems it may have something to do with utf8mb4 vs. utf8 for the server collation. Does this sound right? The dB server is set to utf8mb4_general_ci and it won’t let me change it to utf8_general_ci. My host is Rackspace Cloud Sites, now owned by Liquid Web.

Thanks,
Bob H.

Hi @AmauticUse:

After some further searching and help, looks like the dB server/Innodb engine should be set to use barracuda file system. large prefix, and default dynamic row format, but since I’m in a shared environment I cannot change those server-wide settings.

Looks like another option is to upgrade to MariaDB vers. 10.2 as apparently it increases the max. column width by default, but again I cannot do that since I’m in a shared hosting environment and my provider does not yet offer vers. 10.2.

I received one comment that perhaps I can modify the SQL file that scripts the dB to use ROW_FORMAT=DYNAMIC but not sure that will solve the issue w/o the server-wide settings above.

Perhaps my path of least resistance is to use another hosting provider that can support it, or fire-up a server that I control

Thanks for your help!
Bob H.

I am also using CloudSites on Liquid Web and encountered this same issue. I changed 3 files and was able to complete the installation.

The first was /plugins/MauticSocialBundle/Entity/Tweet.php where I made these changes:
line 153: change the length from 280 to 255
line 214: change 280 to 255

The second was in /plugins/MauticSocialBundle/Assets/js/social.js where I made this change:
line 76: change 280 to 255

The third was in /app/migrations/Version20180117141613.php where I made this change:
line 40: change 280 to 255

Once I made these changes I dropped all the tables in the database (via phpMyAdmin) and then tried the installation again and it completed successfully and I was able to log in. I haven’t gotten very far in testing things out to see what this might break, but since I’m just now trying out Mautic and I probably won’t be using it for Tweeting (I don’t use Twitter much) I’m hoping I can do the rest of the stuff without issue. Hopefully this helps others out. :slight_smile:

Hi Erik:

Thanks for that info. I already installed it using another host and it installed “out of box” w/o requiring any mods. I think Liquid Web Cloud Sites is running an older version of MariaDB. They should update their infrastructure to allow us to select MariaDB vers. 10.2. I’m not too happy with them after they started charging us for the previously included email accounts. I feel like we already pay a premium for the account, though I guess if you’re running many sites it may work out to be a bargain.

Thanks again!
Bob H.

Hi Bob,

Yes, I too was upset when they decided to start charging for the email accounts. This really through a wrench in things between me and my clients who I suddenly have to start charging more for the services I offer them. Things have been steadily declining over the past couple years - even before Liquid Web took over, and so I’m starting to look at other options. The hard part is that I have 100+ sites hosted on CloudSites so that is a lot to move over.

Anyway, glad to hear you found another hosting provider to put Mautic on. :slight_smile:

Hi Erik:

Were you able to get the cron jobs running? Liquid Web’s UI for Cron jobs will only allow a file path and thus we cannot enter command like “web/content/app/console mautic:segments:update”

Thanks,
Bob

PS. And it won’t let us schedule the minute to start, i.e. 0,15,30,45 for one job and 5,20,35,50 for another job. I think cPanel is much more flexible than Liquid Web’s UI.

Hi again Bob,

You are correct that cPanel is much more flexible than the CloudSites UI - in many, many ways. :slight_smile:

I started working on getting the cron jobs to work and ran into the same issue you described - only being able to call a file path without passing the parameter. Obviously this won’t work. I had a chat with their tech support team and what they suggested was that I write a simple script (in perl/python/php) that calls the Mautic php script with the parameter. That script could then be executed via the cron panel. Assuming that worked properly, then I would have to schedule multiple corn jobs that call that same script to run at the specified frequency for each parameter.

Conceptually I understand what needs to be done, and while it sucks to have to do a work around like this, if it works, then I’m “ok” with it. I have not yet had a chance to work up those scripts (other tasks have taken precedence) but when I have some spare time I’ll work on it again. If I happen to get it working, I’ll come back and post here how I did it. If I can’t get it working, then I’ll have to try a different hosting provider. :slight_smile:

Best regards,

Erik

Hi Erik:

I created php files to execute the Cron jobs but they’re not working.
For example, for the Segments Update job, I created cronsegmentsupdate.php with code:

<?php
exec(“php app/console mautic:segments:update”);
?>

I placed the php file in the /web/content/ folder (root for the site), and created the cron job to run the php file. But it’s not working. :frowning:

I would like to host Mautic on Liq. Web since no addl. cost for added sites, and we need to get our $$$ worth now that they’ve started charging for the prev. incl. email accounts!

Cheers,
Bob H.

Thanks for that additional info. That’s the route I was thinking to take. I’ll tinker with it and see if I can find something that works. If so, I’ll share how I did it. I, too, want to get my money’s worth out of LW, and Mautic may play a role in that if I can get it working.

Hi Erik:

Think I figured it out. In Cloud Sites UI, select curl script type w/URL to php file, instead of selecting php script type. For the php file, the code I’ve entered above does work (funny to hear me use the work code; I’m not a devloper!).

Cheers,
Bob H.